Forums Forums Website News 7.1.5 GS:E Change question

Viewing 6 posts - 81 through 86 (of 86 total)
  • Author
    Posts
  • Eddie Percy
    Grunt
    Post count: 8

    Oh guys found this guy who posted this fix and it works for me but its just to get it running until we get updates later.

    Ok, just so everyone knows, I have already posted how to fix this. But clearly people are not following those instructions.. If you want to fix yours you will need to do this.

    Download the Latest GSE: Gnome Sequencer Enhanced: Advanced Macros..

    That is the one on THIS PAGE.

    Do not download the BETA.. Download

    It will be Version: 152.. How to check this? Open your gs-core.toc file and look.. Should say Version 152 on line 5.

    Of if you use the Curse Client.. Click on Versions and you will see

    11/03/2016 GS-E 1.5.2 Release Installed

    Once you have THAT VERSION

    Open up the file called startup.lua

    In there go to line 421.. This line should read

    if specID > 15 then

    FROM THAT LINE add in –in FRONT of all line from line 421 – 425.. so it looks like this..

    — Check if the specID provided matches the plauers current class.
    function GSisSpecIDForCurrentClass(specID)
    local _, specname, specdescription, specicon, _, specrole, specclass = GetSpecializationInfoByID(specID)
    local currentclassDisplayName, currentenglishclass, currentclassId = UnitClass(“player”)
    –if specID > 15 then
    — GSPrintDebugMessage(L[“Checking if specID “] .. specID .. ” ” .. specclass .. L[” equals “] .. currentenglishclass)
    — else
    — GSPrintDebugMessage(L[“Checking if specID “] .. specID .. L[” equals currentclassid “] .. currentclassId)
    — end
    return (specclass==currentenglishclass or specID==currentclassId)
    end

    Save that file…

    If you do this right it fixes it.

    avatarrichard
    Stone Guard
    (Contributor)
    Post count: 149

    just d/ld new gs2 from curse names of macros show up in the viewer but not in the macro list or create macro

    avatarwalt
    First Sergeant
    Post count: 80

    My modified ones still work fine nothing canged

    Uthers
    Grunt
    Post count: 6

    I just want to follow up and state that the editing of the file worked for me as well.

    I downloaded Notepad++ which made the editing a little easier, then verified that I had the full version of GSSE installed, not the beta or alpha release.

    I was then able to find the lua file and then I edited the file as mentioned in this thread. Instead of reloading my UI, I exited out of WoW and then logged back in and was able to access my shortcuts as before. I sometimes received errors when trying to open gsse but everything seems to be in working order and I was able to complete world quests and yesterday’s world boss without too many issues.

    avatarSneedel
    Grunt
    Post count: 8

    I cant find the startup.lua is GS-Core file all there is GS-Core.toc and gsCoretoGSEAdaptor.lua could someone direct me to the startup.lua. it seems im not the only one having problems finding it

    Jessica C Sanfridsson
    Grunt
    Post count: 2

    I had the startup.lua file in gs-core yesterday, today I updated the GSE addon, as I thought the problem was solved. Now the startup.lua is gone. *sad face*

    Can you download just the startuo file from somewhere?

Viewing 6 posts - 81 through 86 (of 86 total)

You must be logged in to reply to this topic.