GSE_2.3.00-BfA-Beta12 good for 8.0 or?

Home/Website/News/GSE_2.3.00-BfA-Beta12 good for 8.0 or?