7.1.5 GS:E Change question

Not sure what happened… but I logged on today and now all my GS:E macros are missing and when I copy and paste it wont load the spec I am in. I checked around and no one else has reported this issue and when I went to the curse.mod site apparently it was updated and few others have stated the issue? I didn’t update my GS:E but now none of my macros work… is this due to the game update?

yep im having the same issues here. typed /gsse and nothing is showing up for my mage at all. not sure about alts yet havent tried them. ok just logged on my alt so its not just 1 character but possibly all of them GSE not working

same here

when i type /gs i get

Message: Interface\AddOns\GS-Core\Core.lua:546: attempt to concatenate local ‘specclass’ (a nil value)
Time: 01/10/17 12:21:20
Count: 4
Stack: [C]: ?
Interface\AddOns\GS-Core\Core.lua:546: in function <Interface\AddOns\GS-Core\Core.lua:535>
Interface\AddOns\GS-Core\Core.lua:642: in function ?' Interface\FrameXML\ChatFrame.lua:4385: in functionChatEdit_ParseText’
Interface\FrameXML\ChatFrame.lua:4053: in function ChatEdit_SendText' Interface\FrameXML\ChatFrame.lua:4089: in function &lt;Interface\FrameXML\ChatFrame.lua:4085&gt; [C]: in functionChatEdit_OnEnterPressed’
[string “:OnEnterPressed"]:1: in function <[string ":OnEnterPressed”]:1>

Locals:

i get this on login with my frost mage

Message: Interface\AddOns\GS-Core\startup.lua:422: attempt to concatenate local ‘specclass’ (a nil value)
Time: 01/10/17 12:23:20
Count: 1
Stack: Interface\AddOns\GS-Core\startup.lua:422: in function GSisSpecIDForCurrentClass' Interface\AddOns\GS-Core\startup.lua:537: in functionGSAddSequenceToCollection’
Interface\AddOns\GS-Core\startup.lua:580: in function `GSImportLegacyMacroCollections’
Interface\AddOns\GS-Core\startup.lua:595: in main chunk

Locals: specID = 253
_ = 253
specname = “Beast Mastery”
specdescription = “A master of the wild who can tame a wide variety of beasts to assist $Ghim:her; in combat.”
specicon = “INTERFACE\ICONS\ability_hunter_bestialdiscipline”
_ = “DAMAGER”
specrole = “HUNTER”
specclass = nil
currentclassDisplayName = “Mage”
currentenglishclass = “MAGE”
currentclassId = 8
(*temporary) = <function> defined @Interface\AddOns\GS-Core\langs\preinit.lua:116
(*temporary) = “Checking if specID "
(*temporary) = 253
(*temporary) = " "
(*temporary) = nil
(*temporary) = " equals MAGE”
(*temporary) = “MAGE”
(*temporary) = “attempt to concatenate local ‘specclass’ (a nil value)”
L = <table> {
is unknown. = " is unknown."
No value = “No value”
As GS-E is updated, there may be left over macros that no longer relate to sequences. This will check for these automatically on logout. Alternatively this check can be run via /gs cleanorphans = “As GS-E is updated, there may be left over macros that no longer relate to sequences. This will check for these automatically on logout. Alternatively this check can be run via /gs cleanorphans”
sequenceIndex: = “sequenceIndex: "
Step Function = “Step Function”
Reloading Sequences = “Reloading Sequences”
has been added as a new version and set to active. Please review if this is as expected. = " has been added as a new version and set to active. Please review if this is as expected.”
Clear Errors = “Clear Errors”
Matching StepFunction = “Matching StepFunction”
No Help Information Available = “No Help Information Available”
Colour and Accessibility Options = “Colour and Accessibility Options”
Incorporate the second trinket slot into the PostMacro. This is the equivalent of /use [combat] 14 in a PostMacro. = “Incorporate the second trinket slot into the PostMacro. This is the equivalent of /use [combat] 14 in a PostMacro.”
Prevent UI Errors = “Prevent UI Errors”
Store output of debug messages in a Global Variable that can be referrenced by other mods. = “Store output of debug messages in a Global Variable that can be referrenced by other mods.”
Disable Sequence = “Disable Sequence”
Setting Editor clean = "Setting Editor clean "
none = “none”
Received Sequence = "Received Sequence "
Use First Ring in Postmacro = “Use First Ring in Postmacro”
Line : = "Line : "
equals currentclassid = " equals currentclassid "
. Overriding with information for current spec = “. Overriding with information for current spec "
. This version was not loaded. = “. This version was not loaded.”
From library = " From library”
Close to Maximum Macros. You can have a maximum of = "Close to Maximum Macros. You can have a maximum of "
. As a result this macro was not created. Please delete some macros and reenter = ". As a result this macro was not created. Please delete some macros and reenter "
Ready to Send = “Ready to Send”
Picks a Custom Colour for the Mod Names. = “Picks a Custom Colour for the Mod Names.”
Source = "Source "
Selecting tab: = "Selecting tab: "
Yes = “Yes”
: Your current Specialisation is = ": Your current Specialisation is "
Only Save Local Macros = “Only Save Local Macros”
: To get started = ": To get started "
GS-E Plugins = “GS-E Plugins”
. You can also have a maximum of = ". You can also have a maximum of "
Picks a Custom Colour to be used for unknown terms. = “Picks a Custom Colour to be used for unknown terms.”
Registered Addons = “Registered Addons”
GnomeSequencer was originally written by semlar of wowinterfa

Yes, GSE will need updated in due time. Follow here:
https://wowlazymacros.com/forums/topic/7-1-5-jan-10th/

It will be fixed. Timothy will update the community.

For the time being…if anyone is familiar with original GS, it still functions just fine. (not quite as user friendly as GSE is, but can be figured out with some effort)

updated in Due time? most authors bother to test during a patches ptr, not wait until the whole thing dies on users first.

This is a Temp fix until Tim has a chance to update.

Quick fix for right now load up startup.lua and go to line 421 and add in – (two minues) before the line do that for lines 421-425 like this

--if specID > 15 then
-- GSPrintDebugMessage(L["Checking if specID "] .. specID .. " " .. specclass .. L[" equals "] .. currentenglishclass)
-- else
-- GSPrintDebugMessage(L["Checking if specID "] .. specID .. L[" equals currentclassid "] .. currentclassId)
-- end

That will fix it for right now… Doesnt matter about a print message

[quote quote=39124]This is a Temp fix until Tim has a chance to update.
Quick fix for right now load up startup.lua and go to line 421 and add in — (two minues) before the line do that for lines 421-425 like this
–if specID > 15 then — GSPrintDebugMessage(L[“Checking if specID “] … specID … ” ” … specclass … L[” equals “] … currentenglishclass) — else — GSPrintDebugMessage(L[“Checking if specID “] … specID … L[” equals currentclassid “] … currentclassId) — end
That will fix it for right now… Doesnt matter about a print message
[/quote]

Ok I found the startup.lua in the GS core folder and scrolled down to line 421. I then put two minus signs before each line and now it works!

[quote quote=39124]This is a Temp fix until Tim has a chance to update.
Quick fix for right now load up startup.lua and go to line 421 and add in — (two minues) before the line do that for lines 421-425 like this
–if specID > 15 then — GSPrintDebugMessage(L[“Checking if specID “] … specID … ” ” … specclass … L[” equals “] … currentenglishclass) — else — GSPrintDebugMessage(L[“Checking if specID “] … specID … L[” equals currentclassid “] … currentclassId) — end
That will fix it for right now… Doesnt matter about a print message
[/quote]

I copy and pasted the above and I have a black window on login. I need to hit close four times for it to go away. Unable to load gsse and macros don’t work.

I then changed to two minus signs and it works. Thanks above poster ^.^

I too am having the same issue. Really shows how dependent I am on these macros as the only thing not macroed is my healing specs. Please provide fix asap.

same problem here waiting for fix

First of all, thank you, Tim, for the great work! I know you’re probably stressing out about getting addon updated, and I just wanted to let you know your efforts are appreciated.

With that said, does anyone know how to get our sequences out of GSE so we can put them into core GS while we wait for the update?

Where and how is that startup LUA? i don’t /cant find it

This fix did work for me, and all of my scripts are now working.
Thank you

[quote quote=39134]

Alger wrote:
This is a Temp fix until Tim has a chance to update. Quick fix for right now load up startup.lua and go to line 421 and add in — (two minues) before the line do that for lines 421-425 like this –if specID > 15 then — GSPrintDebugMessage(L[“Checking if specID “] … specID … ” ” … specclass … L[” equals “] … currentenglishclass) — else — GSPrintDebugMessage(L[“Checking if specID “] … specID … L[” equals currentclassid “] … currentclassId) — end That will fix it for right now… Doesnt matter about a print message
I copy and pasted the above and I have a black window on login. I need to hit close four times for it to go away. Unable to load gsse and macros don’t work. I then changed to two minus signs and it works. Thanks above poster ^.^ [/quote]

That didn’t work at all neither did the first one, all my macros will not work at all. I try /gs and I get an LUA error every time. The only attacks that work are my piddly little auto attacks

I’m fury warrior if that helps people on helping me out there

The startup.lua is located in …
\World of Warcraft\Interface\AddOns\GS-Core

[quote quote=39115]updated in Due time? most authors bother to test during a patches ptr, not wait until the whole thing dies on users first.
[/quote]

The author of this FREE addon owes you nothing. They do have lives outside of what they do involving the addon. It will be fixed when he has time, or when someone else in the community (looks like someone has already found a temp fix) is able to help out with a fix.

Until then, you’re welcome to go elsewhere.

Alger! i think i love you thanks for the workaround

for those saying it doesn’t work don’t copy/paste what he black boxed, find the info for line 421 add 2 – at the front of the line consecutively no spaces between. then remove the 2 spaces after the dashes in to keep everything copacetic to the original coding(not sure if it’s necessary though)

[quote quote=39150]

Mmogal67 wrote:
updated in Due time? most authors bother to test during a patches ptr, not wait until the whole thing dies on users first.
The author of this FREE addon owes you nothing. They do have lives outside of what they do involving the addon. It will be fixed when he has time, or when someone else in the community (looks like someone has already found a temp fix) is able to help out with a fix. Until then, you’re welcome to go elsewhere. [/quote]

And you are welcome to move along yourself Sir. If you bothered to read the response to us users over the last two weeks it was stated that there would be no issues with this addon come patch day. Guess what? there is it’s totally broken. Then the next statement is a lame … “in due time”. Frankly I never asked for your feedback, so keep it to yourself.