Elemental Shaman Macro Shadowlands 9.0.1 - Leveling - Much Potential

Hello and good afternoon everyone!.

First of all, remember game is in beta phase /ptr ( some addons working atm )

Because of mostly abilities and cooldowns are now a bit unpruned , its just
a simple castsequence priority

Did mine with my macro external software logitech gaming software, but ofc you can do it
with Corsair Utility Engine, Steelseries Engine, Razer Synapse, Autohotkey, etc…

105 MSEC KEYPRESS

UPDATED 27/08/20 ( BLIZZARD UNMADE FULMINATION, BACK TO MAELSTROM )

I have been tweaking a bit my main character and this is what i got:


TALENTS

1 , 2 , 3 , 2 , 2 , 1 , 2 ( Earthen Rage, Echoing Shock, Static Charge, Storm Elemental, Ancestral Guidance, Surge of Power, Stormkeeper )


…::: SINGLE TARGET MACRO :::…

d0JldaGAOI6LqL8wv41KcZer1Lv1SjXHHCtsPFrv9nOs9CPStqTxLDtz)eopPQHHu(nQgiurgkI0GjA4iKdcvvNwOJbCosAHKklLQKflOLdLhwvQEQKLHKlfvWeruMQatgHA6IUic6XO8mPY1Pk2ivPSveWMHQy7qv5JiqZsQAAivURkAKiv5HqvA0GyCQ0jjf9zQ4AiI7Huv3gKoouH2gv6bwWGbRk6HFTesEPjmbjNWbtTGvbiL3Y2kavhffGAf(9Kq4yRiZ74a(0JZC7B4ezEmHulNySveSiKapwlYTbt5sdSslY8Gu00YhdFVLrUnDRi7XdYJsoyWkcn8WXypE5qjcLOWOsm1pDRkIEMMKnykxQvArmmobESwKBTfmyWcgmyLpd1sHKeaj0izWuR8zOwkKDu0auKm4Uv(mulfYdJZGGm7vIMZPqEPrh1GPBLpd1Y2JJEEJ9c5HXzqqM9krZ5uiX(2N0pryoFkKcj4E7UQ9cj4EbQU9cj4EbQU9cj4EbQU9cj4EbQU9cj4EbQU9cj4EbQURiNZjI8i0yUcSkalAA8jy6wrVhr8cxb)mnw4kDVsUWvEfnhWcxrkVLArmm(cgmyLpd1sH8W4miiZELO5CkKavGBhDdMALpd1sH8W4miiZELO50Z4qdr5PqcuVaADdUBLpd1sH8W4miiZELO50Z4qdr5PqcuV0CX9Yv46171R8O2VGLR8kAoulCvaw004tQPBfUE9KI9T2cgmyLFIWC(8ThQEH8W4qqyqpfYdIFeXNlxv5tK38ySmYTvKIf5yXu)ksXETiggFbdgSYNHAPqEyCgeKzVs0CofsGkWTJUbtTYNHAPqEyCgeKzVs0C6zCOHO8uibQxaTUb3TYNHAPqEyCgeKzVs0C6zCOHO8uibQxAU4E5k8YHgIYPB5YLl3a

SHAMELSINGLE

Talents: 1232212

This macro contains 1 macro version. This Sequence was exported from GSE 2.6.01-alpha17-shadowlands.

Macro Version 1

Step Function: Priority

Pre Macro: Earth Elemental, Fire Elemental, Stormkeeper

KeyPress: Contains various utility functions.

Main Sequence: Lava Burst, Lightning Bolt, Earth Shock, Flame Shock, Echoing Shock

Post Macro: Earth Elemental, Fire Elemental, Stormkeeper

…::: AOE / MULTI TARGET MACRO :::…

d4t1caGAqKEjkWBvfBtiDPsQmtuOlR0SHQddCtuYVuHBdLopk1ovv7vA3e7NIFcc1WeIFJyGGIgkO0GP0WbvDquuNwWXq1XjPQfsswkjLfRswovEiivpv0YG0ZPQjcHMkPAYqKPR4IqupgPNPkDDOyJGaBfK0MbPSDquFee0SGGPjunosmsqIVbcz0Qu3vfDsqHptkxdu5EOGEyiIZjuEnkYLx9(5ntOWmlKzKzig5(rREtDa(kJVjh9ffLJ2KzmZnX1erirDqMnKsK1dteXigllcsUMqyImuxNpqK(rJgH3KfqWaWHHmRdYRmbIuvnrCHgad(0pVjla1rG668bI4RE)8Q3pV5bf4hJfooCrGRF0MhuGFm2x0iCu46)T5bf4hJ9bMumopXHGqO3arw8GODASr5kkO9hV5bf4hJ9ri0BGilEq0onwUIs84VnzKqGNXa2W0mEtyj(HfG6ivVFEZdkWpg7JqO3arw8GODAS8y8OVX7hT5bf4hJ9ri0BGilEq0qGsWEbMtJLhtHh5T)3MhuGFm2hHqVbIS4brdbkb7fyonwEmLirHOonHYcqQxn)lLPE1u1Ip9QPAbrJ3RMqNG9cmvvtgSSH1TEF17N38yaoTDwzXY2yFeYnWH90yFqAbiD2pAZdkWp(v9ywHUg7JqO3arw8GODASU1VddhGtBhJ1y5kkVkXqWyfm44DAYGLTAl(c8B170u3feM2bTQAQ7cct7WRQMQfen0E1ew3YcqDKQ3pV5bf4hJ9ri0BGilEq0onwUIYRsSonZzHhcWi0jqKMW6cexyy3PtZe(Lcde7hnkAtKfOrC0f6eSWdgWvapmSRQoDAba

SHAMELAOE

Talents: 1232212

This macro contains 1 macro version. This Sequence was exported from GSE 2.6.01-alpha17-shadowlands.

Macro Version 1

Step Function: Priority

Pre Macro: Flame Shock

KeyPress: Flame Shock

Main Sequence: Chain Lightning, Echoing Shock, Lava Burst, Earthquake

Post Macro: Earth Elemental, Fire Elemental, Stormkeeper

TIME TO RUN / HEAL MACRO

#showtooltip Astral Shift
/castsequence reset=30 Healing Stream Totem, null
/cast Astral Shift
/cast Gift of the Naaru
/cast Healing Surge
/use ( whatever item u want here, belt, engineer, flask, potion, etc… )
/script UIErrorsFrame:Clear()


Will try to do an enhancement one too!

so lets keep the macros comin!

1 Like

wheres the macros, you didn’t post :wink:

its on enhancement subforum

seems to lock up waiting for flame shock to come off cd when switching targets

Hello @larry-dumas1

Try to /castsequence reset=target Flame Shock, null and call it on your main castsequence macro.

OR

Make another macro by itself and go sequential

Cheers.

1 Like

Hello @lloskka
Sorry for the dumb question… But can you specify what you mean by call it on your main catsequence ?

I got the same problem then larry, locking sometimes when switching target… I need to use a skill ( exemple Healing surge) to get the macro to fire again.

Thank you very much

And if you go to go sequential ( 2 macros firing at once ), make another macro with /castsequence reset=target Flame Shock on key press section.

Then with your mouse software or AHK, go sequential pressing keys 1-2 1-2 1-2 ( from 100ms to 200ms ).

Cheers

I tried the technique shown in the video, no success. As you can see in the screenshot, I have put pause timer of 18 seconds (so Flame Shock would fire every 18 seconds), but it is either not working (fires the first time, never fires after). I have stripped down the macro to a bare minimum to test it out.



Any help would be greatly appreciated :slight_smile:

1 Like

Hello @captainq

Im gonna reproduce the same as you ( gimme 20 min )

Meanwhile try to put it in KeyRelease ( and not in keypress ), and change your MS for testing purposes ( around 140-50 )

Cheers.

So, after testing it more than 30 minutes I REMEMBER NOW.

It doesnt work at all on shaman, even when its a bit better on KeyRelease.

Checked the GCD debug window, and honestly i have no idea why its not working as intented.
Obviously i think it has to do with the internal “possible” hidden GCD of flame shock ability.
That, or click pause system is bug in some form

@gunnar-wetzel-2 asked me to try on retri paladin too, so i will and then comeback

But a “fix” is to add a few more lightining bolts on your castsequence, an add a flame shock on the end of it.

That will surely work.

Cheers.

yeah I also tried a bunch of variations with no success. Thanks for your help though, really appreciated :slight_smile:

try this instead. i got it to work for me.

  1. Start create one new macro, name it whatever you want. I named it Flame.
  2. In Premacro type this:
    /cast Flame Shock
    /cast Flame Shock
    In Sequence type this:
    /cast Flame Shock
    /click pause 18 (whatever seconds you want)
    /cast Flame Shock
    In Post Macro type this:
    /cast Flame Shock
    /cast Flame Shock

nevermind. it worked once then never again.

i tried this macro and just hangs after flame shock. removed flame shock it hand on frost shock. how do i do this? lol