Elfyau's (GSE 3) 9.2.7 Blood Death Knight Macro **Updated 12-Oct-22**

I think it should be 0.25 - if I recall the razor is setup in seconds

Yes it is in Seconds, tks a lot 0.25 it is XD

1 Like

Hello Elfyau,

Actually, i’ve been a huge fan of GSE since Legion and now i’m just getting into BDK things.

I found out that there is ALOT of BDK macros in here but yet NONE of them showing ANY DETAILS reports screenshot after XX Sec of using.

SO It’s kinda hard to “gadge” ourself and figure out if something is working well or not when a creator is claiming HIS MACRO is great or not.

What i’m mainly looking for here is for a macro that will put HEART STRIKE on top of my damage meter as well as keeping that nice 30-60s rotation going with Shackle the unworthy and Dancing rune weapon. Keeping it on a roll with blood boil, death strike and whatever needs to be in there…

People are never clear enought it seems…

When it comes to comparing a macro to another, we’d like to know the different parameters around it:

  • iLvl of current character

  • Spec / Talents / Stats

  • Screenshot of DETAILED [Details] after 60/120/300s

  • In game MS used on mouse autoclick

  • And such…

To me, all the macros im trying for BDK doesnt seem to work since my HEARTSTRIKE is never on top of the damage done of the rotation. I need to figure out why it is like this and if i am the only one in this situation.

Can somebody help me out with this please because i really think i could do more than im actually doing and seeing my melee autoattacks ABOVE heart strike brang me here to post this and get help to get it to work.

Please, also… is this DETAILS ok ?
Becasue i feel like it’s WRONG af…


its a basic rotation being used i find if you pay attention you can use your spells yourself on certain things i spam DS and Heart when i need to and i do fine. i would suggest you take it to gambit area and test it before you make posts, just play around with it to how you like it, the author makes them how they like not how you like it, so you gotta adapt it to your playstyle

1 Like

I edited the macro to replace all death strikes to be cast with MarrowRend instead to ensure the max amount of bonearmor charges , i attached Deathstrike to a Ctrl modifier so you have more control over when you need to heal, great macro though!

1 Like


I have some questions regarding your comment.
Could you be more precise?
have you just added /cast [mod:ctrl] Death Strike?
Or do you have added a new rotation to optimise Death Strike and heal ?

Many thanks,


This is how i changed it best for me , i removed death strike completely from rotation , and only made it essentially a RP generator and use Shift as a RP spender [Death Strike], i removed all the CDs because i have my own custom “oh shit” macro set up for when things get heavy, as well as removing Deaths Caress in place of Blood Boil, before macros i never saw the reason to use the skill and ive been a DK main for the past few expansions now, and lastly i removed heartstrike and replaced it will all Marrowrend because if youre tanking you should want to keep max stacks of bone shield up as possible, i lowered the ms to 150-200 for a little better responsiveness all and all the original sequence was great though

1 Like

Thanks for your addition this I been playing with it and like how you customized it =) Thanks for the base macro as well Elfyau! I been using your macros for all my guys over the years and you do a awesome job!

1 Like

The macro has been updated and is now available in the original post and via Curseforge. Let me know what you think, Cheers! :drop_of_blood:

1 Like

thanks you Elfyau for your hard work and dedication to make the game better for us.cheers.

1 Like

This macro is not working for me.
GSE Freshly updated.

Pressing the button… Nothing happens.
Deleted the macro, reinstalled it…

Still nothing.

@Deetzee sorry to hear it. Is anyone else having the same issue? please let me know.
Did you try re-creating the icon?

try a game reload after importing the macro seems to fix most of my issue of macros not working at first

1 Like

Been trying, yes. Still didn’t work.
So i basically decided to use your old macro with modified commands.

Been relaunching the game, refreshed the cache, uninstalled GS and reinstalled it with your macro; still not working with that last version.

And yes my spec was the one suggested by your edit ^^

Something is making this macro unreadable.

I just deleted and reimported the macro, and it is working for me. i know you heard this, just didnt see you say you tried it.
have you checked to see how many macros you have already under the “/m”?
if you are using a program for running the macros, is it still assigned to said spot you have the macro set?