GS-myMacros will not load

I have been through the steps to setup myMacros. I read what is on the forums, and i even copied a shaman macro from my regular sequences file to the shaman.lua file in it. Called it something different, restarted game. The initial macro in the sequences file shows up, and is usable, but the one in Shaman.lua in GS-myMacros wont. I have turned this upside down, and i can’t figure it out. Help please?

i have since reinstalled all GS related addons and it still won’t detect myMacros…any possible help?

Only taking a stab in the dark but in the new folder do you also have the .toc file pointing towards your new folder?

in the new folder, the toc file has the same name as the folder, as instructed in the tutorial videos that are on the forum, and the data in the files also follows those instructions.

Basically, since the macro works on sequences but not on the shaman.lua in the other folder, it’s safe to say that the game is not seeing the files in this folder…

Here is a trouble shooting Checklist.

1 - Is the addon in the Addons folder. ie c:\path\to\World of Warcraft\Interface\Addons\GS-myMacros If it is here you should be able to see it in the list of addons before you log into the game. If it doesnt show here either the GS-myMacros.toc file has an error or the folder is in the wrong place (common mistake is to put it c:\path\to\World of Warcraft\Interface\Addons\GS-Core\GS-myMacros)

2 - Is GS-myMacros enabled?

3 - If you look at the ingame GS-E options is GS-myMacros listed there? see
If this is not listed then it didnt process ingame properly. This means you have a CODE Issue.

  • Check that you have all the right matching {}'s ""'s [[]]'s ()'s etc.
  • Check that all the quotes are " and not " same with single quotes.
  • Check that each .lua file in the mod including custom added ones are referenced correctly in the .toc file. WIthout this GS-myMacros has no way of knowing if your sequence file exists.
  • Check that every .lua file including custom added ones start with local Sequences = GSMasterSequences Without this the GS-E has no way of knowing that your sequences exist or not.
  • 4 - Can you see your sequence in the editor? (/gsse)

    5 - Does a /gs refer to a malformed or incomplete sequence? You are missing the E parts of GS-E from your sequence. If you are an old skool GS user you know what to do. If you don’t you need to fix the sequence.

    6 - If you disable every mod except GS-Core, GS-myMacros, GS-SequenceEditor does anything on 1 2 3 4 or 5 change?

First of all thanks for the reply, TimothyLuke

After spending another two hours checking everything back and forth, i simply deleted all the addons again(i had done this before), along with the older instance of gnome sequencer (although that was disabled)

Turns out that after reinstalling and touching nothing except adding macros in the individual files for each class in myMacros, all is working.

Still no clue to what happened, maybe i messed up some option or edited something i should not have. Working in the IT support area, i know well enough there is a good chance the user (me) messed up somehow.

Again, thanks for all the help.