GS not working

I tried to add a ret pally macro to my GS lua, but when I added it, it started messing my monk macro up, now after reinstalling to try and recover my monk macro profile, i’m getting this error - [GnomeSequencer] syntax error on line 3 of Sequences.lua unexpected symbol near ‘?’ - This happens when I login to WoW. Line 3 is associated with the name of my macro - I have tried renaming the macro multiple times.

Here is a copy of my monk macro I am trying to get back up and running:

local _, Sequences = … – Don’t touch this

Sequences[‘WwMonk’] = {
StepFunction = [[
limit = limit or 1
if step == limit then
limit = limit % #macros + 1
step = 1
step = step % #macros + 1
PreMacro = [[
/console Sound_EnableSFX 0
/targetenemy [noharm][dead]
‘/castsequence [nochanneling] Jab,Tiger Palm’,
‘/cast [nochanneling] Rising Sun Kick’,
‘/cast [combat] Fists of Fury’,
‘/cast [nochanneling] Jab’,
‘/cast [nochanneling] Chi Wave’,
‘/cast [nochanneling] Blackout Kick’,
‘/cast [nochanneling] Jab’,
‘/cast [nochanneling] Leg Sweep’,
‘/castsequence [nochanneling] Jab, Jab, Energizing Brew’,
‘/cast [nochanneling] Expel Harm’,
‘/castsequence [nochanneling] Jab, Jab, Jab, Jab, Jab, Jab’,
PostMacro = [[
/use [combat] Serenity
/use [combat] 14
/script UIErrorsFrame:Hide();
/console Sound_EnableSFX 1

Please let me know what I’m doing wrong, I cannot seem to figure this out - as well as I would like to know if it is possible to have multiple toon macros on 1 file or if I need to make multiple copies of the Sequences Lua to have multiple toon macros for my WoW experience. Otherwise thanks for the new addon - it’s been a fun experience.