GSE 3.0 Revert Editor

Hello Everyone, downloaded the new update today. Is there any way to change the editor back to the old style? I personally am not a fan of this block style it was changed to. Any help is appreciated Thank you!

4 Likes

I’m also not a fan of the new style of creating macro’s. I’m completly lost to be honest.

3 Likes

Yes, sir ! Pleeease, give us the old one back !!!

1 Like

The same dont like the new interface of gse 3.0 . Please give us back the old one

1 Like

Id be interested to hear why he decided to change it. The other one seemed to work fine and many amazing macros came out of it. I cannot see a reason to have it changed. This new way is so clunky and hard to follow

2 Likes

Although I REALLY do not like the new editor layout I could work around it’s clunkiness, but I just noticed he completely removed the options for loop style. Considering basically all of my macros rely on using Priority loops and the update essentially forces Sequential on every macro this is an absolutely terrible abysmal change; severely reducing the performance of my macros. Also, even with this neutered version I am getting constant hangs with half of my abilities not firing past the first use. I love your addon Timothy and couldn’t have played wow at a reasonable level without it since I have bad arthritis, but there is not a single positive thing about 3.0. You have created an abomination of UX and have managed to remove extremely important functionality in the process. This is so bad I have a serious suspicion you’re preparing to add paid services to return functionality, like Curseforge and the youtube app have done.

WowUp is showing an update as of 1 hour ago. Maybe he already reverted it. Servers are down for maintenance so I cannot check at the moment.

Edit: Got in before shutdown, he has not, same block layout after update applied

He cannot sell any part of an addon as far as I know. Blizz basically banned all that nonsense back when Carbonite was a paid addon.

Blizzard turns a very blind eye to paid-partial-services as long as there’s no charge for access to the base addon, see: TSM, Zygor’s quest helper, Method Dungeon Tools during the short period the developer had a breakdown. He could certainly get away with charging for a couple option boxes. That said I was being pretty hyperbolic with that last line; seeing my favorite addon being butchered so badly just got me worked up :confused:
I’ll just be using the last 2.xx release and pray he reverts the changes.

I checked the hour ago update before posting hoping the same as you. It didn’t change anything meaningful, it just fixed minor bugs.

I am looking for where to post issues on the github but every time i post about this issue it doest pop up in the issue list. Not sure what I am doing wrong. Not familiar with github

Ruined an almost perfect editor… The Post Macro had great utility for me, not only that deleted the spells I had there it also looks shit. I do respect the work they put into keeping the plugin alive, really helped us and without it would be worse but don’t turn into Blizzard Activision and ruin something that had an intuitive editor. Please please please revert the editor!

What a bad day to do this as well when the patch is out and people need to change their macros…

Please go to [ENH]Revert Editor UI back to old style · Issue #890 · TimothyLuke/GnomeSequencer-Enhanced · GitHub and comment on the issue i put up there so we can get his attention!

2nd this please, i cant use it like this it makes me want to rage quit lol

1 Like

Give us old versione! This new interface is shit!!!

The new version has all the functionality of the old version including loops and pre and post macro. You guys just need to read the wiki on it. I’ve included a screenshot as an example of a loop macro. The pre and post macro stuff were changed to a variables so you add something off the gcd like purifying brew as a keypress variable then you put keypress in each of your blocks.


I believe the advantage to this new method is you can do more things per block allowing more flexibility.

1 Like

While I appreciate your input, this doesn’t change the fact that the new interface causes more problems than it fixes. Most of the macros that i was using before the update are sluggish or dont work at all now. Many of us simply ask to have the old editor back.

2 Likes

yeah before it had “keypress” “premacro” “sequence” “keyrelease” “postmacro”
Now I cant find postmacro, as I always used that for my filler spells when nothing else available…
and i swear the loop doesnt work the same anymore

2 Likes

It does work the same. Just put your filler spell at the bottom of a loop + priority list macro as by definition it will only fire if nothing else is available ahead of it. I sincerely doubt after all the effort was put in to update it that timothy will change it back. I understand it’s confusing at first glance but it took me just a few minutes to understand the basics of it after reading the wiki.

1 Like

To break it down the sequence portion of the gse 2 macros were broken into blocks so each line of the sequence is it’s own block. However you can add more stuff per block now if you want to. You don’t need pre and post macro as you can put that stuff into variables. You then put the variables into each block if you want them always to apply or you now have the flexibility to only apply them to certain blocks. This is an example of something that was not possible before. If any of this is incorrect and someone with more knowledge wants to correct it feel free to do so.

1 Like

i understand how it works, its just silly. postmacro is gone, and loop doesn’t make sense, it used to go around the sequence the loop limit say 5 times, before it used the filler spell. i tried it as you say, and it will fire off lightning bolts a lot more frequent, missing earthquake and lava burst procs … sucks now

1 Like