GSE3 Completely Broken

I can’t use the addon because it’s not updated. It’s the only way I’ve played the game for a long time so I’m stuck now. When can we get back to playing the game with an update fix for 10.0.7 version?

1 Like

10.0.7? we just got 10.0.5. your asking for something that wont be available for a long time. and for the GSE not working, its working fine for everybody else at this moment.
The latest GSE for public is 3.1.28.
have you tried seeing if a addon is causing your issues?

its 10.0.5 sorry. Working for my other toons. dont know why its brokedn on one.

1 Like

Many classes has changes in Talent tree so its 100% why it aint working.
My warlock macro was shit but i had to make some changes and it works again.

Dude, just chill. This happens almost every large patch. Many addons break, including GSE. I found, in my case, that MobInfo2 was causing problems with GSE. You will notice that not very many people are complaining about GSE being broken, which means the problem is most likely on your end.

Act logically. 1) If your going to complain about GSE being broken, explain in detail what the problem is so that someone might help you. 2) Disable all your other addons and try using GSE alone.


not that far away it would seem



yeah i just saw that this morning. ty for posting that.

It’s only my Ret Pally. My Prot works. All my other toons work fine. I’ve tried different talent builds. I’ve tried several different imports. They all worked perfect until Tues.

The problem in detail is that it doesn’t do anything. Like when I press the key, it does nothing, no change. The icons are all question marks

If it’s just one spec of one character - it’s not the mod, it’s the GSE template(s). Until you fix or remove this it will continue to be broken. No amount of uninstalling and reinstalling GSE will fix a broken template imported into the mod.

I’ve got several templates that are all not working. Like 6 that I’m trying. Remove them all and re-import?

Start with the broken one that’s all ?’s. And don’t reimport. Reimporting broken stuff that doesn’t work will only bring you back to the same problem.

If that removes all your ret macros … you may need to look at writing a new one.

Patch changed things a few days ago. Blizzard does this periodically when that happens some things change and some stay the same.

Templates released pre this patch, and yes I know this patch is 3 days long so the number of templates available may be zero, should all be considered broken and non functional unless proven otherwise.

I used one I wrote and it seems to be working. Thank you.