Im Lazy Disc Priest No longer supporting

@imsystem Awesome! Thank you very much! Keep up the good work!

Kind of off topic but relevant Any idea why hitting cntl stops macro instead of firing off? Started a while back and does it with every macro.

go through your ingame keybinds and make sure nothing is bound to ctrl and what ever key your using for the macro. go into gse opeions under macro reset and click clear keybindings see if that helps

ok. Ill do that. I did not remap anything. thats why I am at a loss. I will look again and let you know

clear key bindings in gse fixed it!

Thanks.

SO far so good with the Macro. Have not tried any healing yet.

Thank you for your hard work.

If you are Kyrian here is a simple macro i use for Boon of the Ascended

dSZRcaGAfQ6LQO2fr02ueMnPCyLUjr6xeQUnjEgH0ofXEH2nW(r(Pcj)vuL(TWJjQHQOAWOgUiDqcLtPqXXuPgMcLwOIslvrQftLSCPEOIONcAzKQEUQMOOYujPjtQmDkxuL0PPQll56eSrfI2kHyZky7kk(OcHzPqQpte(UIKrkQk3vfmAr5RIQ4KuPgNOQ6AQqNNkERkYOuOYRvjgVrvm5gHULMxXGtEnj31CyIEufHQRwbShHNDA)cqOycww0i0TY78wPGWraVks1VpayI(je9gHsxGWQ5gyvptbmFaWzrO0vUdrQ(9b4rvm5gvXKBekU8(gXNaHsO7aXhZ)rmrpcfxEFJ4tGqj0D4KsO7aXIQ)4yVffHZJ3KUYDGQOHqOvPJuaiB(aGW5TpAV5GWZLZ0LwTFHQOHW5DjDL7avrdHNlN5D9pQIj3iuCBBjkRaLIdXNar22khqdn0qyEQ9Iyc9(OkAimxnScAgMCJW8vAPiCAbaXcPeBbXs0HqkXXaXkHRN4fOJ40U(N4f4qS0rLJ4lLdXJB1Srt8N5hmIJMyzR1gdXlqhXPD9pXkRCheBbXRS5NzTIyxrai2YkaXJx4nI)0vH4HOjwNqVMpassSBIdGMdXcFrSL5FIhIMyR3pJ40v(Yt8q0epiaKKy1GyxfXzbOEJyVcXGWi(f6I4SykIJMy)aXwwr8zN2VaI)lEnTN4TlINkAlJyH3dKGypG4oS18bqsekY2(1Lw9OkAieMwYUZHj6pobcVcgIwUMmusxBD518MdolAOHia

Usage Information

Run up to group of mobs and press any MOD key (alt, shift or ctrl) and press macro to activate boon then just spam for duration. I only use this for trash packs for fun. To be honest im not sure how or if the Kyrian skills are worth using in rotation.

This macro contains 1 macro version. This Sequence was exported from GSE 2.6.31.

Macro Version 1

Step Function: Priority

KeyPress: Contains various utility functions.

Main Sequence: Smite, Boon of the Ascended

Edited 12/01/2020 Edited macro to be smoother.

Tested the revamped macro last night in Toughast 3’s and mythics. Working well , only issue is at times there is a section of downtime, a few seconds but as disc that is a bit of missed healing/damage. It runs through the initial spells fine, smites once then will sit with no filler where you would usually spam smite until cooldowns are back. Best disc macro I have tried though.

@nicholas-speno Change the inner loop to 2 for both versions of the macro or import the new code from top post. I didn’t realize i changed them to 1. This should help out some. What’s happening is its delaying the rotation cause its trying to cast shield before and after every sequence. You can change the inner loop number to see how well attornments are kept on tank. You may be able to go higher just have to test. Also watch were your mouse is cause if you have it hover over a friendly. Either nameplate body or unit frame it will continually try to cast shield and not do rotation.
The best way to do optimal rotation is to actually remove
/cast [@focus,exists,nochanneling] Power Word: Shield /cast [@player,nochanneling] Power Word: Shield /cast [@targettarget,help,nodead,nochanneling] Power Word: Shield
from both pre and post macro and just manually apply shield with mousever. This way the rotation will not get hung up doing auto shield casts.

@imsystem Updated from the new one before writing the post removed the PWS as noted above since I Use vuhdo to have more control over healing. Still hanging up a bit I’ll have to take a look to see why.

The only time i see hang ups is for like a second usually after casting something instant the macro trys to countinue while the GCD is active. When i first fire of the macro on a dummy it pops cds then does 3 smite with no delay. Its after this time when it reshields and things start coming of cd is when i see the hang ups. Not sure what i can do to fix it. Maybe try playing around with your ms and see if it improves. I have been running mine at 20ms lately.

The macro wont work with game in other language…

Ill try 20 ms that may very well be the reason my normal GSE builds tend to use 100ms. Thanks again for all the hard work!!!

Hi @imsystem
Thank you for this macro!
Unfortunately, all it does seem to do for me is try to spam PWS and nothing else… It looks like it’s trying to cast something else, but gets interrupted somehow?

I tried testing it using 2 methods on dummies:

  1. Put “healing dummy” in focus, spam macro at “damage dummy”
  2. Put myself in docus, spam macro at “damage dummy”
    Talent choice as you described, 3121111.

Tested it at 20ms, 70ms and 100ms, same results.
Any idea why this might happen?

@taishi-daioh make sure your cursor is not hovering over a friendly unit or unit frame. If it is then it will just keep trying to cast shield

I made sure it isn’t. I made a quick video to show what it looks like.

I’ll look into that when I get off work probably 4 hours

1 Like

@taishi-daioh So looks to me that since you are casting shields the macro using the wrong version as one of the versions will not attack unless in combat. However i reimported the code from post as a copy and it wouldn’t even cast shields for me. Not sure why as the other macro that is exactly the same works fine. Long story short delete the macro icon and delete the macro then import the code from main post. Hopefully that should fix it

1 Like

Will try that later, thanks a lot mate!

It worked! No idea why, but it works now :smiley: Thank you so much for your help!

Update: This had been working like a dream, got rid of the healing parts since I use a healing mod to manage that. Running at 20ms smite is filling in nicely. Thank you so much for this!