Macro not working on gse after maintenance

Ive tried importing different macros and making my own but whenever I use keybinds nothing happens using in game ui and uninstalled and reinstalled addon worked fine yesterday

I am having the same issue.

same here i have gone as far as deleting all macros then uninstalling the game and all addons reinstalling in to a newly named directory only loading GSE from zip files hit the button and nothing . was working fine a few days ago then just stopped in the middle of a session now i have to rebuild my entire setup and still no GSE …

1 Like

Same here, my caracter doesn’t move

Linking the answer once again as looking and finding it seems to be hard: ActionButtonKeyDown or ActionButtonKeyUp and Why this matters Macro Cycling not firing · TimothyLuke/GSE-Advanced-Macro-Compiler Wiki · GitHub


Hello please excuse me have you pictures of how to set all this because I do not understand at all the manipulations to make that the maccro works even with the link to the images of gse(certainememtn due to my focus handicap)… sorry

1 Like

thank you for the fix, the priest macro is working now


searching ?? i have searched believe me. your insulting snide remarks are not helpful in the least. why not post the answers on this website instead of scattering answers all over the web and hidden in various forum posts … i don’t use GitHub for this addon i don’t use GitHub for any addon. Why not try putting the fix to the add on where people get the addon? like on the main freaking page … sounds smart

With all due respect , you could have asked on discord already ( and theres 2 WLM and patron GSE ).

Everyone would have answer you in no time

Dont be mad at everyone, just think better next time and ask for help here and both discords.


1 Like

I don’t use discord. again, yet another place not here I should have gone. I did ask for help … here on the page, and got it in time … with a bit of an attitude so I gave a little back and now I will add my thanks because it worked. now your chiming in with a little attitude saying I should think better and act according next time LoL cute

I am going to try clearing out GSE settings and files and install fresh from Patreon build. Up to this point, resetting stubs and keybinds and checking the contents of the generated macro regarding actionbutton all haven’t resulted in the macro firing spells for me. Which is odd since yesterday it did. Must’ve been some code corruption either from curseforge or the unzip procedure. So I’m hoping a full clear of the addon and its settings files will put things right for me.

For GSE, GSE’s GitHub IS the official website for GSE. This website is a group of people, an a reasonably significant group, who use GSE but it is NOT GSE’s home. GSE is a mod used by WoWLazyMacros but it is not owned nor maintained by WoWLazyMacros. It is also not exclusively used by WoWLazyMacros users.

When I post documentation or track what needs to be fixed I post it at the official source which is GSE’s GitHub first as every other community of GSE users looks there not here.

Also with the exception of peak times I generally visit here once every two or three weeks.

if you messed with elvui it resets to key up on restart or so i have read i think that is what is causing so many people problems … at least i am almost sure it is what caused mine

that is useful information, thank you.

It’s been fixed per the ElvUi Discord and their latest release.