Macros break if not used for a day

I am seeing a problem when I import macros, and change talents, set them up and they work fine. After I log for some amount of time, I come back and they do not function. I appears as it is only macros I import… arms warrior (Zee) and balance druid ( Elf). My DH and BM hunter work fine (ELF). All my addons are up to date, I use ElvUI. Any suggestions and thanks for the macros.

well keep using them !

that probably your issue. Elvui and Gse have a love hate with each other. you might have to make a decision between Elvui and GSE addons. i decided to get rid of Elvui and switch to NDui. cuz i need GSE more than the really cool UI addon. lol

Thanks for the advice, I’ll try out NDui.

I loaded NDui, removed ElvUI, deleted and reinstalled the Zee Warrior macro and it worked fine. I changed toons and went back and the macro did not run. I’m going to run a different macro. Ugh

What you are describing is more like something is changing the value of the ActionButtonUseKeyDown between sessions. See ActionButtonKeyDown or ActionButtonKeyUp and Why this matters Macro Cycling not firing · TimothyLuke/GSE-Advanced-Macro-Compiler Wiki · GitHub

When you come back and it doesn’t work I would suggest in the first case, checking if the template still exists in /gse and then going into GSE’s options - Troubleshooting - Update macro stubs.

If the template is not present you have a corrupt GSE.lua file and need to export what you want to keep to a text file, close WoW, delete that file from the WTF area, reload WoW and reimport.

If it’s the later you have a mod that is changing settings on you between sessions and need to figure out how you want GSE to play when it is present.


Thanks Timothy, I’ll give that a try. Any other addons you found difficulties with recently?

That is very hard to answer as I use WeakAuras, GTFO, MRT, MDT, Cursor Cooldown, GSE and Big/Little Wigs and that is the complete total of the mods I run.