Not entirely sure if this is a GSE issue or something else

So, this has happened a few times now to me: I’ll be running instances/dungeons, and use GSE macros. On two toons now (Ret Paladin and Shadow Priest) the DPS macros I was using for each character would lock up. Not only that, but no abilities or anything really (such as Herbing) could be used even by clicking. Reloading my UI did not correct the problem, and the issue only reset when I left the dungeon/instance. Just in case, I do use ElvUI.

Has anyone else had this happen recently?

be specific … which macros …

I’ll find them, but the point is, this has literally been my first and only issue with GSE. Ever. It’s just odd that it began happening out of nowhere.

Here’s the most recent one that locked up/began acting strange:


This is Ozy’s Shadow Priest macro.

Ret ST




i looked at it … post yur question in his macro let him answer ya … first impression … it needs rewritten … it just sits there and casts shield and heals on yurself … so ya its gonna lock up because yur out of mana

I posted the wrong one initially; look at the edited version of my post.

oh ozy’s … i dunno post it in his … maybe has something to do with the auto firing of trinkets and rings and everything … i know that messes things up with certain trinkets

I turned all of that off, because I know it can screw with things; I also marked out Heart Essence lines because that can screw things up too when leveling a toon. Anyways, I was just curious if anyone else had come across the same issue.

I’ve had this happen in dungeons before. Every addon locked up (including Elvui). Turned out it was caused by a bugged monster. Even quitting the game didn’t fix it cause it would put me right back in dungeon and the same bugged monster would aggro me. As soon as I was able to cheese it and kill it all functionality came back immediately. Can’t say for sure that’s what happened to you but what you described sounded familiar.

1 Like

Thank you for the insight. That sounds more like it rather than there being a GSE issue. So it was a mob that didn’t, or wouldn’t, die or was somehow aggro’d on to you?

Yeah I was solo in Iron Docks and a mob was upstairs and stuck in a wall and it was sending fire blobs at me through the floor. I kept killing the blobs cause they were nonstop and then my whole UI locked, addons gave errors… I logged out and back in and addons still wouldn’t work. I finally found where the mob was and killed it and then everything worked again.

I have noticed other times not in dungeons where I’ve become “stuck” in combat even though all the mobs have been killed and it effects addons oddly. It’s like they won’t update until you’re out of combat, and since you’re stuck in it, they sort of just freeze. Usually using a hearthstone fixes it. My feeling is it’s probably something along these lines that’s happened to you.

1 Like

Thanks again, Velinn, I’m almost certain what you described is what happened to me because nothing on my UI would work and GSE has never done anything like that to me. I appreciate it!

The “stuck in combat” thing affects Mods rather significantly. Blizzard has a list of functions that mods can use - programmers call this an API, Application Programmable Interface. If it’s in the API you can use it in a mod. (This is why you can’t get banned for using GSE as it only uses what is in the API.).

Now Blizzard has 2 of these. One for out of combat and one for IN Combat. The in combat API is about 10% of the functions from the normal api. While you are in combat, the 10% work normally but the other 90% are still there. But when you as a programmer try to access them you get what is called a tainted execution path. If you have taint and you try to use a function in the combat 10% Blizzard blocks that and completely shuts down your mod. What we programmers then do is detect this and prevent our mods from getting into this situation. The common solution is We as programmers and mod authors start queuing actions until you the player gets out of combat.

I appreciate all of that information, Timothy. Just for clarification, it doesn’t just seem to be a stuck in combat bug, but to the point where I can’t even right click functional items like chests and such to use them. Or does that go along with this potential issue as well?

I’ve been having the same exact problem. Not only in dungeons but also in the hot springs quest the gnome gives in bfa, and also in the class trial for level boost on a horde pally. You can’t click any skills on the hot bar nothing happens. It also happened to me during a boss in the oculus and also on the way to the frost dragon corridor in that northrend dungeon with the ice breath after killing the valkyr chick. It’s very discouraging. I also noticed that I tried to re-import the macro I was using and GS wouldn’t even show the “MERGE/REPLACE” etc window when you import a duplicate macro, but after the alliance attackk in the class trial area, where I was forced to finish it with auto-attack. Suddenly poof the GS window came up asking if I wanted to merge/replace (that window where it shows both macros side by side and there’s a drop down of actions to take. Apparently the event ending unstuck my hotbar. WTF…

EDIT CORRECTION: Yes GS unfroze, but still none of my hotbar skills work, the macro cycles but nothing is cast. Please help!!!

If its blocking all buttons and actions that can quite safely rule out GSE as it just doesn’t have that amount of power. It cant lock any action bar or prevent any action from being taken. (Humour value) I blame Climate Change.


Ive been having the same issues listed here
did anyone find what was making it happen or how to solve it?

Yeah I have been running into the same issue as well, it’s starting to get beyond annoying.

I’m having this same issue, did anyone ever figure out how to fix it?

Yes its been going on about a week now for my wife and i macros will run super slow or not run at all. I hit the start button in game and resume and it will fire again and the quit seconds later. I have reboot my net, game and done reloads and its still going on. Every button that is not a gse macro works just fine.

If you’re using a macro that has any form of /cast or /use Heart Essence in it, try removing that. I haven’t played WoW in a while, but that may be the source of the issue since your character doesn’t have the Heart of Azeroth yet.