ScaryLarryGames Guardian Druid Macro **Updated 10/31/2020**

ScaryLarryGames Guardian Druid Macro: Updated 10/31/2020


Usage Information

Alt=Frenzy Regen, Barkskin, Incapacitating Roar / Ctrl=Survival Instincts / Shift=Berserk

This macro contains 1 macro version. This Sequence was exported from GSE 2.6.24.

Macro Version 1

Step Function: Priority

KeyPress: Bear Form, Berserk, Wild Charge, Frenzied Regeneration, Moonfire, Barkskin, Survival Instincts, Incapacitating Roar

Main Sequence: Moonfire, Thrash, Ironfur, Mangle, Maul, Swipe

Talents 132?311
Created@100 MS

Alt=Frenzy Regen, Barkskin, Incapacitating Roar / Ctrl=Survival Instincts / Shift=Berserk

Tap Shift for New/Close Target > Moonfire once > Hold to Wild Charge (if in range) > Berserk.

This macro will not auto target OR start combat until you tap shift to pick up a target OR manually select a target. Moonfire is locked behind 4 Mangles which forces a refresh every 15 seconds or so. If you want a faster refresh remove one Mangle and save.



Stop by anytime and say :wave:. Drop me a Follow and/or Subscribe if you like the stream and want to support a fellow GSE Macro Creator/User/Gamer! Monday-Friday : 7pm to 11pm EST 8)

:point_right:How To GSE: ScarylarryGames YouTube!
:point_right: Muting ERROR SOUNDS/TEXT/FIZZLE(GCD) in game properly
:memo: AHK Script Toggled by MouseButton5 Spamming Button 1 at Random Clicks Between 100ms-150ms


Tried your macro and i can say, love it already.

Never tanked with bear druid, but im enjoying so far.

With ilvl 120 i can resist for about 35 stacks on lvl 52 tanking dummy ( with proper azerite essences / HoA ).


1 Like
Have this error when click macro

Message: [string “UIErrorsFra”]:1: ‘=’ expected near ‘’
Time: Sun Nov 1 09:56:18 2020
Count: 7
Stack: [string “UIErrorsFra”]:1: ‘=’ expected near ‘’
[string “=[C]”]: in function RunScript' [string "@Interface\FrameXML\ChatFrame.lua"]:2174: in function ?’
[string “@Interface\FrameXML\ChatFrame.lua”]:5073: in function ChatEdit_ParseText' [string "@Interface\FrameXML\ChatFrame.lua"]:4737: in function ChatEdit_SendText’
[string “@Interface\FrameXML\ChatFrame.lua”]:3017: in function <Interface\FrameXML\ChatFrame.lua:3010>
[string “=[C]”]: in function RunMacroText' [string "@Interface\FrameXML\SecureTemplates.lua"]:441: in function handler’
[string “@Interface\FrameXML\SecureTemplates.lua”]:654: in function <Interface\FrameXML\SecureTemplates.lua:602>
[string “=[C]”]: ?
[string “@Interface\FrameXML\SecureHandlers.lua”]:266: in function <Interface\FrameXML\SecureHandlers.lua:263>
[string “=[C]”]: ?
[string “@Interface\FrameXML\SecureHandlers.lua”]:296: in function <Interface\FrameXML\SecureHandlers.lua:279>

[string “@Interface\FrameXML\ChatFrame.lua”]:1626: in function ?' [string "@Interface\FrameXML\ChatFrame.lua"]:5053: in function ChatEdit_ParseText’
[string “@Interface\FrameXML\ChatFrame.lua”]:4737: in function ChatEdit_SendText' [string "@Interface\FrameXML\ChatFrame.lua"]:3017: in function <Interface\FrameXML\ChatFrame.lua:3010> [string "=[C]"]: in function UseAction’
[string “@Interface\FrameXML\SecureTemplates.lua”]:345: in function handler' [string "@Interface\FrameXML\SecureTemplates.lua"]:654: in function SecureActionButton_OnClick’
[string “@Interface\FrameXML\ActionButton.lua”]:108: in function <Interface\FrameXML\ActionButton.lua:102>
[string “@Interface\FrameXML\ActionButton.lua”]:144: in function `ActionButtonDown’
[string “ACTIONBUTTON1”]:2: in function <[string “ACTIONBUTTON1”]:1>

Locals: (*temporary) = “UIErrorsFra”

change /targetenemy [mod:shift,noharm] to /targetenemy [noharm] and it work

@nefrit Not sure why it would give you that error. I’ve tested that both manually spamming and mouse spamming with no error. Also not sure why it would trigger an error because /targetenemy [mod:shift,noharm] are all commonly used commands and conditions.

Is your GSE up to date? If you look at your Error it has everything to do with CHATFRAME.lua so maybe its a UI issue and not a GSE issue.

Just be aware changing that line to /targetenemy [noharm] will cause the macro to auto started and moonfire the target.

My fail. Check once more time. problem with /castsequence [mod:alt,nochanneling,combat] reset=10
Dont know why. but when I delete reset=10 marco start working :neutral_face:


may be
When I add marcos, I have this error

WARNING ONLY: Sequence Named GUARDIAN was not specifically designed for this version of the game. It may need adjustments.
GSE v2.6.24

PS nice macros :slight_smile:

1 Like

I modified this macro slightly to suit my play style. I found it wasn’t keeping Iron Fur up 100% for me (close, but there were gaps). I took maul out of the rotation and this fixed it for me. I have 100% uptime now, and have got up to 5 stacks in M+.

I also changed the modifiers to suit myself. (Shift - Frenzied Regen, Alt - Mangle (for the proc’s and berserk), Ctrl - Mighty Bash (Swap this out for Mass Entanglement when appropriate. Eg. Necrotic weeks).

The Macro works well for me - tanked up to +17.


Not sure how to format it for the Website. Thanks and credit again to ScaryLarryGames for the original.


I dont see it :smiley:

hi, i use Ctrl, it does’t do anything, use Shift will chang to human status, i don’t know why.

@Tom_2020 On My Macro cntl=Survival Instincts, which does not shift you into Human form. In fact the macro when pressed or running forces you into Bear form.

Might be an issue with your keybinds.


:point_right: Muting ERROR SOUNDS/TEXT/FIZZLE(GCD) in game properly

Which covenant might you incorporate into this macro?

@Noob_Noobington I will be updating this mostly next week and it will have a line like my Hunter Macro for any covenant.

If your looking for the right Covenant I think Kyrian might be best according to Icy Veins

1 Like

Doing a reset=xxx on any castsequence in GSE is not a good idea. The entire concept of the reset doesn’t work. Since the castsequence is in the macro, it’s repetitively hit by the addon (even if a spell/ability never fires). That causes the timer on the reset to always be cleared. The concept of the reset was meant for macros that are actually not interacted with the xx seconds before resetting the sequence.

Sadly I don’t believe you’ll be able to do anything about it, other than to take it out.

This macro is no longer supported please see:

ScarylarryGames Guardian Druid Macro