ScaryLarryGames SL BM Hunter Macros **Updated 1/7/2021**

@CoolHunterBoi … I think I know what is wrong. Same thing happened to a friend of mine yesterday. His CTRL key wasn’t firing the macro.

Open GSE > OPTIONS > Macro Reset > HIT The Clear Keybindings

After he did this his CNTL key started working for the macro. if this doesn’t work IDK then because I have several folks that are using it on both BM and MM Specs (Same Macro) and its firing off 100% of the time.

1 Like

@Balanicus I have one up but its the old BFA one. Its over in the FURY War Section. Woe king on leveling my Guardian Druid right now so I can get that one updated.

1 Like

Freaking brilliant thanks so much, worked 100%

1 Like

The traps work like a charm - thanks Larry. Love your macros!

1 Like

Question: Whenever I use the macro, most of the time, it would fire the Tar Trap, then Flare. However, lately, it has been firing off Flare first, then Tar Trap. Am I doing something wrong?


Here is the line that Fires off Tar Trap then Flare
/castsequence [combat,@cursor] reset=2500 Tar Trap, Flare

It shouldnt fire Flare first as the line doesn’t permit it.

BUT you can Change the reset time to 500 and hit SAVE on the TRAPS Macro …

This should still force it to fire Tar Trap first and then be enough time to cast Flare. The RESET of 500 will give you enough time to cast the 1 flare after AND it will also lock it out due to Tar Trap being on CD .

Heya i was having issues with wild spirits and the flare tar combo, So i have added this into the sequence box as first and second line and it now works perfectly, so if you are having issues try this.

/castsequence [mod:ctrl,@cursor] reset=24 Tar Trap, Flare
/castsequence [mod:ctrl,@cursor] reset=120 Wild Spirits

Hey thanks for the tip with the clearing of keybindings but somehow this hasen’t helped neither :frowning: Guess I’m somehow out of luck!

@aceslayer glad it works for you that way. I’ll test it out a bit and update the traps macro.

@CoolHunterBoi Sorry the mod:ctrl isn’t working for you. Does your TRAPS macro have a ICON? If there is a book on the icon spot then it doesnt have an Icon and its not active, therefor wouldn’t work at all.


/castsequence [combat,@cursor] reset=2500 Tar Trap, Flare
/castsequence [combat,@cursor] reset=24 Tar Trap, Flare

Replace Macro OR Open TRAPS change 2500 to 24 and hit SAVE

I didn’t put a reset on Wild Spirits because it is one spell and locks on itself and does not need a reset due to that fact.


Yes that’s the strange thing! Mod:crtrl works fine. It just isn’t firing the trap or wild spirits in your macro for me / the traps Macro does nothing.

It is working in another macro however, at least wild spirits.

That’s what puzzles me.

@CoolHunterBoi IDK then its specific to you then I’m sorry I’m out of ideas how to fix this for you.

Maybe try to delete it and Re-Import it.

Icon Made for TRAPS MACRO?
CRTL Key Keybinds cleared via GSE Option.

Thank you ScaryLarry

1 Like


Did you rename the TRAPS macro to Traps or anything like that …

Becuase The /click NAME function is case sensitive. it has to match the command in the main macro which is:

/click [mod:ctrl] TRAPS

Had the same issue until I realized that I had to install all 3 of his macros above.

1 Like

Yes importing all 3 Macros is a must 8)

Maybe this should always be my first question when someone is having issues with a MOD Key.

Thank you!

1 Like

I can’t get the trap macro to trigger the kyrian spell Resonating Arrow(Kyrian)

It just wont fire. The resot the macro(s) seems to be working just fine.

Thanks for all your support bro! But no its still called TRAPS. Didn’t rename anything. It just won’t fire :frowning:


In the TRAPS macro KeyRelease Box

Change that line one to:
/cast [combat,@cursor] Resonating Arrow


12/9/2020 UPDATE

Removed - TRAPS macro
TRAPS macro Integrated into BM-SGL Macro still on MOD:CTRL

In BM-SGL Macro REPLACE Wild Spirits with Your Covenant Ability and Hit SAVE

Delete OLD versions and RE-IMPORT.

This should help those having issues with TRAPS macro Firing off.