[Solved] Lutechi Macros Cause Errors

When I import Lutechi macros, they don’t show up in the macro list. The built in ones don’t show up. When I reimport them, I get a replace/merge/ignore window but they never show up in the window. I go into the Plugins config and it prompts a replace/merge/ignore window. When I enable “Show all class macros” They show up, but when I disable it, they disappear. When I use them with the “Show all class macros” enabled, I get an error:

Message: [string “UIErrorsFrame:Clea”]:1: function arguments expected near ‘’
Time: Fri Nov 13 12:06:50 2020
Count: 13
Stack: [string “UIErrorsFrame:Clea”]:1: function arguments expected near ‘’
[string “=[C]”]: ?
[string “=[C]”]: in function RunScript' [string "@Interface\FrameXML\ChatFrame.lua"]:2174: in function ?’
[string “@Interface\FrameXML\ChatFrame.lua”]:5073: in function <Interface\FrameXML\ChatFrame.lua:5019>
[string “=[C]”]: in function ChatEdit_ParseText' [string "@Interface\FrameXML\ChatFrame.lua"]:4737: in function ChatEdit_SendText’
[string “@Interface\FrameXML\ChatFrame.lua”]:3017: in function <Interface\FrameXML\ChatFrame.lua:3010>
[string “=[C]”]: in function RunMacroText' [string "@Interface\FrameXML\SecureTemplates.lua"]:441: in function handler’
[string “@Interface\FrameXML\SecureTemplates.lua”]:654: in function <Interface\FrameXML\SecureTemplates.lua:602>
[string “=[C]”]: ?
[string “@Interface\FrameXML\SecureHandlers.lua”]:266: in function <Interface\FrameXML\SecureHandlers.lua:263>

[string “@Interface\FrameXML\ChatFrame.lua”]:4737: in function ChatEdit_SendText' [string "@Interface\FrameXML\ChatFrame.lua"]:3017: in function <Interface\FrameXML\ChatFrame.lua:3010> [string "=[C]"]: in function UseAction’
[string “@Interface\FrameXML\SecureTemplates.lua”]:345: in function `handler’
[string “@Interface\FrameXML\SecureTemplates.lua”]:654: in function <Interface\FrameXML\SecureTemplates.lua:602>
[string “=[C]”]: ?
[string “@Interface\FrameXML\SecureHandlers.lua”]:266: in function <Interface\FrameXML\SecureHandlers.lua:263>
[string “=[C]”]: ?
[string “@Interface\FrameXML\SecureHandlers.lua”]:296: in function <Interface\FrameXML\SecureHandlers.lua:279>
[string “=(tail call)”]: ?


The macro runs and casts spells / uses abilities but the error is constant. When deleted, it reappears.

I’ve tried reinstalling, deleting my WTF folder and changing characters. The results are all the same.

Oddly, other macros work fine.

any output from chatwindow ? you already use the max. allowed macros ?

Sorry for the delay. Got caught up in RL stuff.

I had an unfortunate incident that caused a complete Windows reinstall. Got GSE installed (no other macros) and it worked fine. I realized I hadn’t set any options so did that and got the errors again. After some playing around, it seems the “don’t run macro unless you have a target” is causing the error problem. I do not know why the macros weren’t showing up when I imported them as it works now.

Also, when I enable the “use pants, necklace, rings, etc” options, I get constant “too close / not ready” messages both on screen and spoken even though I have the suppress errors options checked. The sound option just turns off the sound effects, which I don’t like so don’t use. The other two seem to do the job though so I’m not really worried about that.

1 Like