Viktri's (not really) One Button Macro - Dragonflight Guardian Druid - v1.1 BIG CHANGES now with Maul!

seems your talent code is out of date according to Import talents. it wouldnt let me do that. Any update on your talents in your OP or something I missed?

1 Like

I just updated everything.

1 Like

Yes everything is properly changed, unfortunately I was one of the people affected by “unable to initialize” bug when updating the game, so it is a bit later but better than never!

All the new changes including Maul and automated Moonfire are posted!

Trying it out now! Thanks for this!

1 Like

I could be blind and mis read your changes but when I import Macro code v1.1 i’m not seeing anywhere in the macro where moonfire was listed/automated. Was this suppose to be automated or was it taken out?

1 Like

It is automated by the [Galactic Guardian] talent. Edited main post to make it clearer.

i imported this and the Druid part is empty, is this intentional or a glitch? tried it 3 times and get the same result.

1 Like

I will see where the problem is and fix it, thanks.

Fixed, thanks for letting me know.

1 Like

Many thanks.

The talent link kept giving me an out of date error. Assume they are similar to this:

Talents:

BgGAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAASEJJKiCJSkAEJFKCAggEIJJJJJCAAAAAAAQEA

thank you. its working great now.

1 Like

allright got it working. since Im using auto key software (non razor) set at 90ms, seems effective from your macro but Ill continue test to change ms and will see how it fits with. CTRL is what Im using from auto key to runs but I can just press and hold for maul to hit then hit CTRL to turn auto key back on right away. Very nice macro you got for CTRL/SHIFT/ALT. :smiley:

1 Like

Guten morgen, gibt es einen Befahl womit man die STRG Taste auf eine Maustaste legen kann?

Das ist abhängig von der Maus. Ich verwende Logitech G-Hub.

It depends in your Mouse. I am using the G-Hub Software from Logitech.

I will do some research if we can use Mouse 4 and Mouse 5 windows buttons as modifiers in a WoW macro, but I doubt it.

Testing these now! good work so far!

Thanks do much for this!
Quick question,

I’m trying to get the macro to work on my steam deck. I got it imported fine but when I push the button, it is rotating through the icons on the action bar, but it’s not actually using any of the skills(moonfire, mangle, ironfur, etc).
Any idea how I can get it to actually work?

Under troubleshooting in the gse options make sure to click UPDATE MACRO and directly under that option check the action button use.

been doing LFR with your macro. parse results here. but I think because of my ilvl/enchant gears/perform the fights (Im rusty in those raids after long hiatus) but Macro did great job for those though. Im looking foward with your macro for M+ and raid separate talents. :smiley: