Viktri's (not really) One Button Macro - Dragonflight Guardian Druid - v4.2 Ready for 10.0.7

Any idea about the speed? having same issue as above and using LGs mouse around 200 ms . Ty for ur gr8 work Viktri

Hello Viktri! Thanks for responding. I tried it on the Synapse software with key board and mouse tried 50 ms 100ms 150ms 200ms and 250ms same issue with all speeds on both the keyboard and the mouse.

Was testing the macro a little more today. Ironfur being self cast im finding it harder to keep it up 100% of the time like the older version. This mostly happens on big pulls when the macro is running for longer if the dps is lower. I have spots when rage just isnt available for ironfurs cast.

Okay that is a troubling report, can you please copy paste me the Raw Edit of the macro just so I can confirm it exports and imports properly?

Other than that, I will need as much info as specific as possible about when the macro does what, thank you for your assistance in this!

Sure thing here you go Viktri.

{
[“Variables”] = {
[“KeyPress”] = {
[1] = “/startattack”,
[2] = “/stopcasting [mod:alt]”,
[3] = “/cast [mod:alt] Incapacitating Roar; [noform:1, nochanneling] Bear Form; [mod:ctrl, nomod:shift, nomod:alt, nochanneling] Moonfire”
}
},
[“Actions”] = {
[1] = {
[1] = {
[1] = “KeyPress”,
[2] = “/cast [nomod:alt, nochanneling] Wild Charge”,
[“Type”] = “Action”
},
[2] = {
[1] = “KeyPress”,
[2] = “/cast [nomod:alt, nochanneling] Barkskin”,
[“Type”] = “Action”
},
[“Type”] = “Loop”,
[“Repeat”] = 1,
[“Disabled”] = true,
[“StepFunction”] = “Sequential”
},
[2] = {
[1] = “KeyPress”,
[2] = “/cast [mod:shift, nomod:ctrl, nomod:alt, nochanneling] Frenzied Regeneration; [nomod, combat, nochanneling] Ironfur”,
[3] = “/cast [nomod:alt, nochanneling, combat] Raze”,
[“Interval”] = 2,
[“Type”] = “Repeat”
},
[3] = {
[1] = {
[1] = “KeyPress”,
[2] = “/cast [nomod:alt, nochanneling, combat] Mangle”,
[“Type”] = “Action”
},
[2] = {
[1] = “KeyPress”,
[2] = “/cast [nomod:alt, nochanneling] Thrash”,
[“Type”] = “Action”
},
[“Repeat”] = 2,
[“Type”] = “Loop”,
[“StepFunction”] = “Sequential”
},
[4] = {
[1] = “KeyPress”,
[2] = “/cast [nomod:alt, nochanneling] Swipe”,
[“Type”] = “Action”
}
},
[“InbuiltVariables”] = {

}

}

1 Like

I have same issue with above. Ironfur simply not being cast at all. even I have rage available for it to be cast. I clicked on ironfur manually, it casts but when use your macro, it does not cast at all. its like ignoring ironfur. my ms set at 100-150ms.

Are you sure you are not using the template 2? I set it as default for easy content, like outdoors (and raids).

I have tested the template 1 again, and it runs exactly the same as it did in v3, which makes sense since it is pretty much the same with minor changes to how often Ironfur gets activated (1 extra step of Ironfur, zero impact on rotation since Ironfur is off GCD) and removed unnecessary double loop for Thrash and Mangle (they were in a loop that didn’t loop at all and then in their own proper loop, this has absolutely no impact on the execution, but makes the macro cleaner and easier to edit).

What I expect is happening is that the Template 2 is just not as optimized as I thought, and since it was set as default for outdoors and raids, it caused the issues. The v4.1 of the macro has reverted back to the Template 1 being default for all content and people can test the Template 2 for themselves while I work on optimizing it. Sigh.

The Template 1 is seriously so close to the v3 in v4.1… If that ran well for you, the v4.1 with reverted default will run the same. I just did the Mage Tower with that template.
image

using v4 template 1, actually. Only Ironfur do not cast. Without manually clicking.

details1

Now, Ironfur appears here is because I manually click ironfur with macro running.

my ms set at 100ms so I dont know why ironfur simply not casting as it should. v3 has no issues at all with ironfur though. but sadly, v3 is gone from gse because I deleted any old verisons macros. >< I shouldve keep old verison haha.

Wait are you really certain it was template 1? Because that looks damn a lot like template 2! If you set default as 1 but Raids has 2 (or any other place) than that will overwrite default.

Can you send me a pic of your template settings please?


raws

{
[“Variables”] = {
[“KeyPress”] = {
[1] = “/startattack”,
[2] = “/stopcasting [mod:alt]”,
[3] = “/cast [mod:alt] Incapacitating Roar; [noform:1, nochanneling] Bear Form; [mod:ctrl, nomod:shift, nomod:alt, nochanneling] Moonfire”
}
},
[“Actions”] = {
[1] = {
[1] = {
[1] = “KeyPress”,
[2] = “/cast [nomod:alt, nochanneling] Wild Charge”,
[“Type”] = “Action”
},
[2] = {
[1] = “KeyPress”,
[2] = “/cast [nomod:alt, nochanneling] Barkskin”,
[“Type”] = “Action”
},
[“Type”] = “Loop”,
[“Repeat”] = 1,
[“Disabled”] = false,
[“StepFunction”] = “Sequential”
},
[2] = {
[1] = “KeyPress”,
[2] = “/cast [nomod, combat, nochanneling] Ironfur”,
[3] = “/cast [nomod:alt, nochanneling, combat] Maul”,
[“Interval”] = 1,
[“Type”] = “Repeat”
},
[3] = {
[1] = {
[1] = “KeyPress”,
[2] = “/cast [nomod:alt, nochanneling, combat] Mangle”,
[“Disabled”] = false,
[“Type”] = “Action”
},
[2] = {
[1] = “KeyPress”,
[2] = “/cast [nomod:alt, nochanneling] Thrash”,
[“Disabled”] = false,
[“Type”] = “Action”
},
[“Type”] = “Loop”,
[“Repeat”] = 2,
[“Disabled”] = false,
[“StepFunction”] = “Sequential”
},
[4] = {
[1] = “KeyPress”,
[2] = “/cast [nomod:alt, nochanneling] Swipe”,
[“Disabled”] = false,
[“Type”] = “Action”
}
},
[“InbuiltVariables”] = {
[“Head”] = false,
[“Ring2”] = false,
[“Trinket2”] = false,
[“Neck”] = false,
[“Trinket1”] = false,
[“Belt”] = false,
[“Ring1”] = false
}
}

God fucking dammit YOUR problem is that the stupid Interval in Block Path 2 has AGAIN reset to 1! Needs to be 2.

Wait it is all wrong. Just delete the old version and import the new, it’s all messed up.

Did you do any manual edits to the macro? You are free to, that’s why it’s posted unlocked, just wanted to know :slight_smile:

only I edited is just removed frenzied since my alt button bound to other spell. thats it. allright, I deleted whole macro and imported again. this time, I didnt edit, let me know if it still show any wrong or not. Also it shows bright red since I guess you set that way with disable block. In old macro I uncheck that as well.


Yes now it’s proper, you can feel free to delete the Frenzied regen and enable those Barkskin/Charge blocks and it should be good! Fingers crossed, runs perfect on my side.

allright, just tested on dummy, the interval went back to 1. I changed that to 2 again and saved. tested again, now interval stays at 2. seems all good now.

1 Like

Thanks so much for testing this so much for me. I have no idea how to deal with this.

1 Like

Asking in GSE discord, maybe it’s a bug, maybe I am doing something wrong, but for now I put a big warning in the How to use section and I recommend everyone to check that the value for the Interval in Block Path 2 is 2.
image

Please can you also check the new version and the Block Path 2 being Interval 2 as well (despite your raw edit looking fine)? try to update to the v4.1 version by deleting the old macro and importing fresh. I am trying to figure out what’s wrong, thanks :slight_smile: