ActionButtonUseKey check box in the troubleshooting tab of the menu:

On my warrior the macros will not fire unless I have this unchecked. On my hunter it must be check to fire off abilities. This is a new occurrence as of this week. I’ve only ever changed this setting months ago, and haven’t had to change it between characters.

I may be missing this, but is there a way set this per character?

No as it’s not a GSE setting but an account wide WoW setting. A better question is why one class is changing this and fixing that.

I don’t know. I think ill use the command /console ActionButtonUseKeyDown 1/0 and make a macro button one for each toon. That will make it easier to toggle.

Its a workaround anyway.