All imports since GSE3 on cycle thorugh "?" icon, not abilities

Hey Everyone,

I’m not sure if this is the correct area to post this, and while I’ve been around the community a while, I have not posted much. I have never really had any issues with GSE or the macros from almost all content creators. Anyway, here goes:

I have a problem where a few Macros I have tried for DK (all specs) only show the “?” icon when rotating through most abilities. This has only happened since coming back in 9.2. I have ensured I’m on the correct GSE release. I have ensured that I am using macros compatible with GSE3. I have reviewed the text within the macros and see that it is all highlighted and showing the correctly spelled abilities and whatnot.

Is this something I am doing wrong or something I need to change in the macro or GSE?

Any help is appreciated,

Ther first thing to try is fix your macro. GSE looks at the action from the top down and uses that to determine the icon and asks WoW what ability it sees that should be the icon. If WoW can’t figure it out it means there is a problem with your macro. Its usually the wrong abilities like showing hunter pet abilities instead of hunter abilities as people put the pet stuff before the main thing but this is what I would be looking at first. Also look for redundant mods that might be making things weird.

oh so the macro should never show a ? if its runnign right ?

If WoW can interpret it into an ability then yes it shouldn’t be a ? However it depends on how the macro is written as to what it thinks it sees.

That’s what I thought originally, was that the abilities weren’t being named properly, because I’ve seen that in the past and corrected it. However, in this macro specifically, all names are showing as linked to the proper name ability but when I run on 250ms, it appears that about half of the abilities are showing a “?” icon.


@TimothyLuke , this is the macro from this thread, Sl 9.2 m+ uhdk-nf 1-1-3-3-3-3-3 - #14 by xxblynqxx

Others users are reporting no issues and I can’t find any in the macro itself that would be causing this.

I really appreciate you taking the time to reply. Thanks for the help so far!

I just found the debug options in GSE and after reading the chat logs of what the macro is doing, it appears to be functioning correctly, it’s just showing the “?” as the tooltip for certain skills. So I suppose this is possibly just a visual bug? Let me know your thoughts

As I have said GSE asks WoW what icon it sees for each action. If WoW can’t see it you may need to restructure the order of the specific action so that your main ability for the action is more prominent to the top of the action. It’s not a GSE thing it’s a hey WoW what can you see from this compiled action thing.

1 Like