ALT modifier no longer functioning in GSE

And odd problem, that I’ve only just noticed. The alt modifier in GSE doesn’t work for me anymore. Shift and ctrl work just fine. Alt however just blinks the current ability in the queue, but it doesn’t trigger the ability it’s bound to.

I’ve tested the alt modifier with a standard macro and it seems to be fine (it shows the proper function). I’ve removed all addons except gse (just in case something was conflicting). I’ve checked the “macro reset” option and that’s fine. I’ve used the clear rebinds option, and that doesn’t make any difference. I’ve tested it across alts (no pun intended) and the same thing occurs on those characters.

It’s REALLY puzzling.

Can anyone help?

Edit: Below is the macro I first noticed this on, but as I said, it occurs across characters and across macros.

dye(kaWkKI0SqQ(LqmmrQJPqldrpdvAAGuDnrY2uq(MqkJtuCocK1Pa9oqsDpfq)dbzGGeDqawisPhIGAIkOUiiLncsYhrkIrcs4KiWkjq9suXmjaDtcODc0pfsyOeQJsaSurPNQ0urvxfPO2kb1xvaEls6UiXEv9xHenyIomKfdIhtPjlQUmPnJqFweJguDAj9AcYSv0TjKDl1VfmCq54cPA5s8CkMouxhqBxiPVJu48c18rz)u9hp)bh)UIJsarb0oi55)kmQurqMQ58h)Lhn1gB(si6eIoHOti6eIoHOtOVciYGPzy5iSM)Lmnj54izAYrONjv0(UWulbdFWuFfiYwcMZFWXZ)vyuPIGmvZ5)YrJZQtfz0ZFWXVmlrI55ierIrSidMvCjZsKyMmqGKNZSejMkL1Mkf1oyHJ6wN1oHcR4sMLiXmzGajpxyKiy1s16sOjcsbzvwHvoi5xMLiX8CeIiXiwKbZkUKzjsmtgiqYZzwIetLYAtLIAhskbGWO7sOe2efRfkutkbGWOdLedwGgkSIlzwIeZKbcK8CXbAOfxsqteOPgAwHvo(lhnwCrnMZFWXVrSid2LuffYh0aVsetVdw4OU1zTtO4sbw7CxUkQa1UKQOq(GOjMEhSWrDRZANqXLdRrnaSu7exkEIsaQqTlPkkKpOfxM07GfoQBDw7ekUCHJYd0WLdiuYh0LdRim8ds(nIfzWgn6a12QUKAhefYP3blCu36S2juCPlDzrnkEGyujrXU0LlCuEGgUCaHs(GUumQ20DzdCopi3VrSid2OrhO2w1Lu7GOqo9oyHJ6wN1oHIlDPllQrXdeJkjk2LUuyKiy1s16s(aqlC6USboNhF8xawCn0MZFWXZFWXVoZzC0yXf1yCMZoi53iwKb7sQ2GiiimfxssMHCOHoi3VoZzC04S6urg1zo7lFmm9lalUg6Jpi55p44xN5moAS4IAmoZzhK8BelYGnA0bQTvDj1oyHJ6wN1oHIlZKwqK0DzM0cIKUltLj1b5(1zoJJgNvNkYOoZzF5JHPFbyX1qF8b5E(do(1zoJJglUOgJZC2bj)gXImyxsTdw4OU1zTtO4sUrlLGspEqUFDMZ4OXz1PImQZC2x(yy6xawCn0hFqOF(do(1zoJJglUOgJZC2bj)gXImyxsTdw4OU1zTtO4sUqh6C5EqUFDMZ4OXz1PImQZC2x(yy6xawCn0hFWuN)GJFDMZ4OXIlQX4mNDqYVrSid2Lu7GfoQBDw7ekUKKmd5qPpi3VoZzC04S6urg1zo7lFmm9lalUg6Jp(lbneG1jwyuPIGmvZ5)YxQTqkE80(LWbrqq4t73S1oH8q(YxQTqkM80(fuTcDiFHcfLFiFPvN4d5B2ANmEihF8bjp)xHrLkcYunN)lhnoRovKrp)bh)gXImyxsTdw4OU1zTtO4sHrIGvlvRlHMiifKvpi53iwKb7sQDiPeacJUlHsytuSwOqnPeacJousmybAO4sXbAOfxsqteOPg6J)YrJfxuJ58hC8BelYGDjvrH8bnWReX07GfoQBDw7ekUuG1o3Lq1efd1UKQOq(GOjMEhSWrDRZANqXLdRrnaSu7exkEIsaQqTlPkkKpOfxM07GfoQBDw7ekUuG1o3LRIkhK8BelYGnA0bQTvDj1oikKtVdw4OU1zTtO4sx6YIAu8aXOsIIDPlx4O8anC5acL8bDPyuTP7Yg4CEqUFJyrgSrJoqTTQlP2brHC6DWch1ToRDcfx6sxwuJIhigvsuSlDPWirWQLQ1L8bGw40DzdCop(4VaS4AOnN)GJN)GJFDMZ4OXIlQX4mNDqYVrSid2LuTbrqqykUKKmd5qdDqUFDMZ4OXz1PImQZC2x(yy6xawCn0hFqYZFWXVoZzC0yXf1yCMZoi53iwKb7sQDWch1ToRDcfxMjTGipi3VoZzC04S6urg1zo7lFmm9lalUg6Jpi3ZFWXVoZzC0yXf1yCMZoi53iwKb7sQDWch1ToRDcfxYnAPeu6XdY9RZCghnoRovKrDMZ(Yhdt)cWIRH(4dc9ZFWXVoZzC0yXf1yCMZoi53iwKb7sQDWch1ToRDcfxssMHCO0hK7xN5moACwDQiJ6mN9LGgRLOIMhC8lFmm9BwfMIWhFWuN)GJFDMZ4OXIlQX4mNDqYVrSid2Lu7GfoQBDw7ekUKl0HoxUhK7xN5moACwDQiJ6mN9LpgM(fGfxd9XhCOZFWXVoZzC0yXf1yCMZoi53iwKb7sQ2GiiimfxssMHCOHoi3VoZzC04S6urg1zo7lFmm9lalUg6Jp(lbneG1jwyuPIGmvZ5)MT2jKhYx(sTfsXJN2VeoicccFA)YxQTqkM80(fuTcDiFHcfLFiFPvN4d5B2ANmEihF8XFbaedpu(sZTqDGgTlbaedpu(oafjeaGfK58h)vGkgnmcJo)xOqNWM1wOVF5rtTXMV0sGaaainLu4OgTamUaPjjjcql8WL0rJgjeqaTaaaaaaaaaaaaaaaeCDH2YlGcwWcgQiG2GaScrqwcdnHiaQGbvlHb8LMSqtyTyQH(GChjt)faqm8q57xcprgdbdFWuFHwtmuSkHdIGHWii1zfhFA)Yhfe(GJPtNon53HvIiGt8bh)cf6e2xxWUG)kGidMMHLJWA(xY0KJPhjtLwqKKPH(xqKi97kokbefq77ctTem8bjtL57auKqaawqMZF8xbIAGOjbnwlrvBCn0N2Jp(4F

Can anyone assist here? While it’s possible to operate with only 2 modifiers, it’s a bit of a pain.

Otherwise, is it possible to have a separate Shift AND Ctrl modifier?

I wish I could help you with that,
Only thing I can think of going into GSE / options / troubleshooting and clearing keybinds

I’d already tried that. I’m going to try exporting my macro and delete my SavedVariable files. If that doesn’t fix it, then I don’t know what will.

Exporting and backing up won’t fix your problem. Fixing the problem will fix the problem. You need to go through your keybindings manually with your eyes and look for the conflict. If it’s not the common keys you need to look further and in a welcome to dragonflight, some mods have their own keybinding sections that are not show in the keybinding UI section.

In Dragonflight the self cast and auto loot keys are commonly overlooked causes.

Like Tim said, the most common problem I run into is overlapping self-cast with a macro mod key.

ALT being the issue, either disable self-casting or check that the abilities you are using still work if WoW tries to target them on yourself.

And yes, I seemed to have many interface settings revert when 10.0 came out.

I’ve already gone through all the normal keybindings and have nothing bound to an Alt Key. I don’t have anything bound to self case and autoloot is … auto (no keybinding).

I’ve disabled all other addons with only GSE running and had the same problem. No Alt key. So it’s not another addon.

The Alt key works with other macros (I have a mount macro that selects a type of mound depending on the modifier). However, with GSE, it gets stuck on whatever is in the rotation at the time (or so it seems).

Edit: I’ll check again when I get home to see if I missed anything, but I’ve already gone through several times.

If this is the case then it could be the order you have your mod lines in the action.

BUT i will stress this again - you need to check EVERY binding not just the normal ones and the bindings in mods that have their own bindings.

Mounts don’t require an enemy target to cast, either.

Yep. You were right, but it WASN’T and addon and it WASN’T a keybind … in the usual place anyway. It was actually Lock Action Bars … which is a completely different place from every other keybind. Once I cleared that, it was fine!

DAGNABIT! That was driving me nuts for a while now. Thanks for pushing me to check my options again. I would never have thought to look at hte Action Bars location.

3 Likes

This worked for me (SHIFT mod not working). In WoW options, Lock Action Bars used SHIFT (even tho it was unchecked). Changing it (and all others) to NONE freed up SHIFT, ALT and CTRL mods for use!!