ALT Modifier not firing

I’m having a problem with my disc priest macro. Interestingly, no other class has the problem.

For some reason, neither my ALT modifier is not firing. nor is the target reset working on the castsequences. Note: This is purely a levelling macro. I wouldn’t take this to dungeons.

d0dTeaWsrQ8wfITrrfxwPzsrLomWSvH5t1nPi9lvu3weEoO2PIAVsTBrTFOgLif9xkQQFtPbQGyOOObty4uihubQtjsHJrbhxbPfQsYsrblwvlxYdvG8uIwgk06uPmrkIPksMmPPJQZtH60O0ZOOCDfXgva2kfvzZiBxLQVQqAwkuFwL47QiJub14GmAr0JfoPIu3sLuxdK7jsvRub0DvK8ArkDBOt1ZgAjtgmFtMwoOEMXovltbo2mhULgmZGzmAMHwAYsGjh8E2qlhEpmQLYKSehlUglyApTfwmQTuSGbGYcYXIh4G41bwCnwyc7D28IfsoOWdCWhCS4ASyy7HXyXS9oalsZSLJfNSvAzZxWcYwybSnXIf1cGT50OLMcIYAEBbZAZWDQE2qNQNn0spisvaGOZbaMdVdDYMJ1lSWdIGGuncpicckciOrgsc7e41EFRXj3dJgNT6c0XzBKeKZ7bB(YuyrTWlp9CqDz5yHxEHfEqec9VQEqec9VQmTN2clg1w6nSqMKDpuV8Amw4bri0)Q6bri0)Qktcu7jSW0nRE51ySWdIqO)v1dIqO)vL5Mb5y9YREMXw6brQcaeDoaWCVWcpicH(xvpicH(xvMBgKJ1lV6zZAPhePkaq05aaZH3HozZX6fw4brqqQgHhebbfbeewul8Ytphuxwow4LxyHheHq)RQheHq)RQmjqTNWIrTLEdlycyZE51ySWdIqO)v1dIqO)vvMGLVE51ySWdIqO)v1dIqO)vvMGLVE51ySWdIqO)v1dIqO)vvMGLVE5vlzAH5McIY2PAElhEbA)TCEJ02FlVAp493sgyZxm0Flt3Amd7XcG3ovpBOLEqKQaarNdam3lSWdIqO)v1dIqO)v1CzVKKdBe4u2lVAElt3AmZAHH7u9SHw6brQcaeDoaWCVWcpicH(xvpicckciOrsy1BWjzj(uEHfEqec9VQmTN2clg1w6nSGbGYcYX6Lx9mJT0dIufai6CaG5EHfEqec9VQEqeeueqqJKWQ3cEDmLxyHheHq)RQjS3zZlwi5GYlV6zZAPhePkaq05aaZ9cl8Gie6Fv9GiiOiGGgjHvVbo4t5fw4bri0)QoS9WySy2Eh4LxnVLmWMVWy)TKzTMcIY2PAElL81ObmjhCwBULmlwBXYnU5nVLdEcpPTA5v1cYzBEidOSW8e2jvEBP0OnM2KEMriZPLMcYtahtN5BDFZCwBUVQ5nVBaUsage Information
Shift - Power Word Radiance
Ctrl - Divine Star
Alt - Holy Nova (not working for some reason)

This macro contains 1 macro version. This Sequence was exported from GSE 2.4.03.

Macro Version 1

Step Function: Priority

/cast [mod:shift] Power Word: Radiance
/cast [mod:ctrl] Divine Star
/cast [mod:alt] Holy Nova

Main Sequence:
/castsequence [@mouseover,help,nodead,nochanneling] reset=target Power Word: Shield, Shadow Mend, Penance
/cast Penance
/castsequence reset=target Shadow Word: Pain, Smite, Smite, Smite

/cast Lightspawn

Double check that your alt is not keybinded to your macro button. Like My alt-1 used to be my defensive cooldown. Since I put my macro on action bar “1” the alt modifier didnt work until I unbounded alt-1 in my keybindings

Thanks, but no … it’s not. I use the same keybindings for all my characters. Nothing is bound to the ALT key. In fact, my gse macros are always bound to the Q key for all my characters.

I found a workaround after a while, but it really didn’t make a lot of sense why this worked and other things didn’t. The new version looks like this …

Step Function: Priority

/castsequence [nomod] reset=target Shadow Word: Pain, null
/cast [mod:shift] Power Word: Radiance

Main Sequence:
/castsequence [@mouseover,help,nodead,nochanneling] Power Word: Shield, Shadow Mend, Penance
/cast [nomod] Penance;[mod:alt] Holy Nova;[mod:ctrl] Divine Star
/castsequence Shadow Word: Pain, Smite, Smite, Smite

/cast Lightspawn

Maybe someone with a bit more knowledge could explain.

Edit Again
DAMNIT! Did all my testing in Stormwind and it worked. Zone back with the same macro and the ALT key doesn’t work again. This is beyond bizarre. A bug perhaps?

Edit Yet Again
I’m not sure where to find the detailed debugger that’s in the screenshots, but I’ve displayed the keypress modifiers and the ALT key seems to halt the macro execution completely. Release the key and it starts again. I’ve checked my keybinding and I have NO binding to any variation of ALT key …

… once again, this is the ONLY character this occurs on. Other characters don’t have this problem.

Another Edit (hopefully the last one)
It appears that one on my addon profiles had gotten corrupted for that character. I reset them one at a time and BINGO! Hopefully it sticks.