Auto attack on and stay on

Anyone found a good way to turn this on and keep it on consistently without messing with macro? Most of the problems I have are with switching targets with no mana.

/cast !auto attack

tried but messes with macro

should be
/startattack

I haven’t sorted autoshot yet. /cast Auto shot and !Auto Shot works but it makes it spaz out trying to recast it.

1 Like

yeah /startattack only seems to work for melee. I made a macro with just /startattack and it never starts attacking ranged.

Yeah ranged will be /cast Auto Shot.

Made a GSE thats just /Cast Auto Shot

worked for me. want it? ill post it

EDIT

it only SEEMED to work, when i turned on YAHT, WeaponSwingTimer, it showed that autoshot is atcually getting toggled on and off very fast.

Kinda Works, but not idea.

Why not put /cast Auto Shot into the pre macro and not set. Loop limit. It will cast once and then not until you exit combat.

Most of the problems I have with it are switching mobs with no mana. Auto shot starts automatically when you use a shot. But without mana it just sits there doing nothing. its not a big deal really I just start auto shot manually. The loop limit idea would work well if it would reset on target also and not just combat.

yup gom jabar, thats a big problem. Rank 1 autoshot you might be able to use with very low mana, maybe on a priority gse , how would we write that? clicking from spell book always gives full power. maybe.

this is how we did it on vanilla private servers, fall thru macros like this + GSE would be such a great combo if they can be made to work.

/cast Arcane Shot(rank4)
/cast Arcane Shot(rank 3)
/cast Arcane Shot(rank 2)
/cast Arcane Shot(rank 1)

worked very well for mend pet.

might work. ill go look at the wowinterface page, time to learn this crap for real.

Sounds great timothy! I dont really know every part of HOW GSE works, i take ham fisted trial and /castsequence error, error, error, error, WORKS!, error, erorr…

That will great for my Begginner wow , right now it turns off n on.

But unfortunately wont help with the autoshot toggles off when you turn away problem. The hunter community is pretty sure they will hotfix it soon, being able to run away and jump shot, or strafe shot is pretty much most of our pvp. ca6ca

Another alternative is putting rank 1 arcane shot on a repeating macro, the trouble with that is you cant use full power arcane shot.

Hel peeps,the long Queues on Globby are really helping me be a forum …added tooer…?

HERE is the solution to keeping autoshot on.

/cast [rank 1] arcane shot

it wastes a cooldown, but ours are only 1 second long. had a hell of a time figuring out how to make downranked spells in a macro.

Ill give that a try!
/castsequence [rank 1] reset=target arcane shot,null
gonna try this also

If you solved this problem you would find a significant decrease in the amount of time you spend in trial and error. A lot of problems you are trying to solve by reading through this have already been solved for you hence the options that GSE gives but instead of using those solutions you are blundering in the dark.

/cast Arcane Shot(Rank 1)

Is what you are looking for. Your other is a mod and will do unpredictable results. What you are asking is IF I’m trying to cast rank 1 then cast rank 1.

Huh? What? Why are you sharing Arcane Shot when dude was asking for Auto Shot?

Does anyone have Spammable Auto Shot GSE?

So for example, instead of hearing a ton of gun clicks I can just spam the heck of a key and it’ll stay on? Any ideas?

I tried this, but not luck: /castsequence reset=target !Auto Shot, !Auto Shot, !Auto Shot

Cause i was replying to the downranking question:

/cast Arcane Shot(rank4)
/cast Arcane Shot(rank 3)
/cast Arcane Shot(rank 2)
/cast Arcane Shot(rank 1)

worked very well for mend pet.

I have /cast !Auto Shot in my macro it works fine

1 Like

Just made a macro with
/cast !auto shot

and it does seem to work but my toon spazes out trying to cast it over and over. So it may be just a graphical/sound thing but not a performance issue.

I have mine in the key press, and it works fine for me. Alternatively put it in the pre-macro, without a loop set, and it will only activate once.

in the pre macro seems to work well, or leave it out, they seem to have fixed the issue , did some jump shot kiting last night.

WHY did i give a downranked arcane shot? if you try to spam /cast auto-shot over n over it spazzes out, as another poster said, turning it off and on. Arcane Shot would start autofire (but also put arcane shot on cooldown, so i dont know what i was thinking tbh.).

Got back into my hunter. This is my current solution that works pretty well.

/castsequence reset=target/6 Auto Shot, null

just add that as the top line or prob would work keypress too.

Hosting Favorite Streamers