Best way to switch to new GSE?

Hello Everyone,
I have used 1.5 for a long time and have done the fix to keep using it but I know I will have to change to 2.0 and was wondering what is the best way to do this. First just downloading from curse or go into World of Warcraft/Interface/AddOns and remove all of GS 1.5 and then do a fresh install to bypass any bugs that may happen.

wondering the same :=)

  1. Got to WOW\WTF\Account&lt;<YourAccountName>>\SavedVariables and save your GS-Core.lua file.
  2. Also save Interface\Addons\GS-* myMacros etc
  3. If you use Curse to update your mods, get it to update GSE.
    3b. If you dont Delete GS-Core, GS-DraikMacros, GS-SequenceEditor, GS-Translator and then extract GSE to Addons. This will have two folders. GSE and GS-Core.
  4. GS-Core is disabled by default. If you enable this, It will add a plugin - GSE Legacy Adaptor. It will attempt to import your GSE1 macros. If it fails you will need to manually import these macros by editing the old lua files and copying them and then importing via the Import GUI

Things to note.

  • /gs and /gsse now do the same things. /gs opens a Macro Browser. From here you can select a macro and drag it to your action bar.
  • GSE1 plugins are not compatible with GSE2. GSE2 uses a different syntax and API. The Legacy Adaptor attempts to bridge this but if the macros were not totally compliant with GSE1 there may be challenges.
  • Unless you write a GSE2 plugin you wont be able to edit outside of the editor. There is on GitHub a reference plugin. THe HP Macros Plugin has been updated to GSE2 and can be looked as as a sample to base from.
  • GSE2 doesnt automatically create an Icon for each macro. (In 2.1 the GUI has the option to create the macro on import.) You need to select the macro and choose Create Icon and then drag the Icon to your action bar.
  • DraikMacros have been replaced by a smaller set of Sample Macros. These can be loaded at any time from the Plugins Tab in Options and you will get a prompt when you login to a character with no GSE Macros asking if you want to load these macros. Editing these sample macros in the LUA files will not automatically load in your macros. Also replacing these with GSE1 macros will crash the mod.
  • Macros are stored in WOW’s Mod Storage area WTF. These files are maintained by WOW and only written to disk as the WOW application is shutdown. The file for GSE2 is WOW\WTF\Account&lt;<YourAccountName>>\SavedVariables\GSE.lua
  • Macros without a SpecID will import into an area Called Global Macros. editing these macros and changing the SpecID to your class will result in a performance increase.
  • PreMacro and PostMacro have changed - See KeyPress and KeyRelease vs PreMacro and PostMacro
  • The GUI will import GSE1 macros to a point. GSE2 is a complete rewrite from scratch.

no matter how many times ive tried i can not get the app to open up in game useing /gs /gse
ive been trying for a few days to no avail. i looked everywhere for a way to get it to work and nothing. it works in game just wont open the app in game but if i make a macro with the name gnomesequence1 it works and goes through the steps but i can not add new macros as ./gs does nothing??? what am i doing wrong???

Are you trolling or what? You asked the same question How to install GS-E + Macro's and I responded. All the instructions you are following are now over 4-5 years old and completely obsolete. Go to the other thread - follow the link, download the mod, copy it to your addons folder, open the game, type /gse and go go go go go

If ANYTHING you are installing Gnomesequencer and good luck with that - you need GSE if you want any of the commands you are tryiung to use to work.

1 Like

sorry no i was not trolling i figured the issue out. i did get it to work but i had to uninstall and reinstall all of my wow and launchers and everything. I’m thinking somewhere along the way it missed something in an update? im un sure as my friend downloaded it and it worked for him right away but took me to reinstall the game to get it to work. sorry for the questions.

thank you for making this amazing app though its allowing me to play wow again as i suffered an injury 2 years ago that’s made use of my left hand very minimal. this app helps me a lot!!!

Glad it came through. Ons of the worst things about the internet is you can’t tell tone 90% of the time.