Cant make new macro's

Until like 15 mins ago, I was able to create my own macro’s, but now when I type “new”, creating macro, and pressing save, it wont save it! :frowning:
and now I cant make any macro’s at all, I’ve tried to update it to the newest version, but still same problem :frowning:

you might of hit the macro limit. your allowed to make only so many macros on all toons total.

then what do I do?
delete other macro’s and it will work out?

sorryu was in a boss fight and coudnt elaberate. go through each toons macros and delete any that you dont need or want.

toons? I have macro’s on 9 classes, U mean the macro’s on them?

toons are your characters, get rid of any you dont use or need.

Things to check:

1 -Are you in combat? GSE cant complete the save action until you leave combat. This commonly happens when testing a macro on a target dummy. GSE has an out of combat queue that you can monitor from the Minimap icon or a LDB feed.

2 -Are you able to save other character? GSE stores macros in a “bucket” per class. There is a mage bucket, a pally bucket etc. As GSE Macros are more binary than text, you may have a corrupt macro that is breaking a class bucket. To fix that /gse forceclean followed immediately by a logout and login (THIS IS VERY IMPORTANT) will reset that classes bucket. I would recommend exporting any macros for that class that you want to keep first.

3 -If you are not able to save on any character you may need to completely exit the game and delete the GSE.lua file located in the c:\path\to\WoW\WTF\Account\YOURACCOUNTSNAME\SavedVariables folder. Removing this file will completely reset GSE for all your characters and wipe any macros you have installed.

Other errors that get confused:

  • Wrong Version- You are playing on an older version of GSE and the macro you are trying to import wont work on that older version - Update GSE
  • Too many character macros - GSEcan store an unlimited number of macros however WoW needs a macro stub located in the /macro interface of WoW. You can store 18 character macros and around 100 account macros in this space. For macros that do not have a stub, GSE has a Blue Book as the icon. in /gse Select the macro and hit the “Create Icon” button to create the macro stub which you can then drag to your action bar. Sometimes when you import, it mports the macro but cant create the icon until you either delete some Character Macros from/ macro or in GSE’s options select to overflow into your Account macro storage.

Things to do simply WONT DO SQUAT TO FIX YOUR PROBLEM:

  • Uninstall GSE / Reinstall GSE. This isn’t Windows. The problem will be in your data storage. if you dont fix that you wont fix your problem.
  • Reload UI. Again the problem is in your data storage. Reloading will just wipeany actions you may have taken to fix the problem and just reload the problem.