Changes are not being saved

I am new to Gnome Sequencer (or enhanced). So I presume the problem is because of the way I am doing things.

I have gotten a macro sequence to run, but it has problems. So I need to make multiple edits. Here is what I am doing.

First time, I use /gsse, then use the drop down to find my macro, then click on edit, and make my changes, then save, then close. That gives me a saved message in chat.

Then I use /gsse, which show my macro name in the drop down, but the main window is blank. I then click edit, which then shows my macros. I then make my changes, click on save. But save doesn’t say saved, and my changes are not saved, even if I click multiple times. (This took me hours of frustration last night, as I assumed it was being saved.)

Is this a bug, an issue, or something I am doing wrong?

Next question, is there a way to watch the macro being stepped through? Or is there a guide to the order that the things will be processed? (I have done some programming, most recently in C#.)

Thanks for the help. This program is a big help since I have to game while in bed/laying down.

Hello Sean,

Regarding on how to watch what the macro does, you are probably looking for the debugger feature. You can see how it works on this video:

About the saving problem, I am not at home to do a test or help you with that further, but here is a video that might help you out:

Thanks. Looking at the second video makes me think something is not working as intended with GS-E regarding the Save button, or the Edit button (related to the drop down?).

The debugger looks great, just what I was looking for. (It would have been nice if the video told you how to open the window at the beginning. But I see it covered it later.)

I tried it again tonight. If I do /gsse, then edit without using the drop down, then make changes, then save, I will not get a saved message.

If I /gsse, use the drop down to select different sequence, then select the original sequence, it will then show the sequence in the viewer, clicking edit, making changes, then save, will give me a saved message.

I thought the dash “-” was to comment out lines? If so, using either above method did not save the dash.

Lastly, the debugger show the sequence name, then a number (4,7,8,9, etc). It does not show a spell. Is that right? And I tried running it where some things where being casted, but others weren’t, and I never saw in the debugger that it was casting. It always says “Not able to cast”, “resources Available”,and “Not actively casting anything else”. The only thing that changed was GCD Free or GCD in Cooldown.

Hi Sean

This is part a bug but its working as intended. The bug part is that it still shows your macro name in the dropdown. It was requested that the box clear when you reopened it.

When you go back into /gsse if you select any other macro and then your current macro this will then behave for you.

Comments are not saved. use the helpTxt line.