Crushing Blow / Bloodbath Macro Cheese

So I’ve done a lot of playing around with GSE/macros while trying to fine tune my own personal gse macro, and in my efforts I’ve realised something that is extremely useful especially for a fury warrior using the reckless abandon talent and decided to share it here with you guys in case you don’t know.

/cast Crushing Blow
/cast Rampage

or

/cast Bloodbath
/cast Rampage

Yep. When multiple spells are written out in a macro like this it will try to cast the first existing spell. Keyword being existing. If you do not currently have the reckless abandon buff from casting rampage crushing blow and bloodbath do not exist and therefore the macro will cast rampage instead.

Now you may be thinking “But doesn’t the blizzard ui automatically change the names of spells to their current version?” Apparently it only goes one way. A macro with the bloodthirst spell will change between bloodthirst and bloodbath depending on the buff, however a macro saved with the spell as bloodbath does not cast anything except bloodbath and won’t ever change it to bloodthirst.

This is super useful in ensuring maximum reckless abandon usage and minimal wasteful raging blows over rampage, and I hope you guys make use of it to greatly improve your dps like I have :slight_smile:

1 Like

Nice tip, already edited a test macro and forcing only crushing blow when available… Makes me happy putting bloodthirst at high priority and not seeing raging blow charges at 0… for me this is already giving me 2-3k dps increase in st

Just be aware that GSE stores the BaseSpellID. If you want to force a spell to a version, use $$ as the prefix. This will force it to stay a particular way

eg
$$/cast Rampage will force it to stay Rampage irrespective of whether you have the buff or not. GSE is changing spell when changing forms · Issue #669 · TimothyLuke/GSE-Advanced-Macro-Compiler · GitHub

So doing the $$ like this


Would stop GSE from changing that line back to raging blow, even if i switch to a different spec and back?

Yes apparently I need more characters to meet min post length but yes

This was incredibly helpful. Thank you Endless!

Tried this, it stays like this in the editor, but did a dungeon and it switched back to raging blow and got stuck in raging blow, but the editor says its crushing blow. So the macro locked up. Do i have it set up correctly? Crushing blow is the upgraded version of raging blow , so when i have reckless abandon up it turns to crushing blow, otherwise it is raging blow.

I had this issue as well, and I’m not entirely sure on the problem being with GSE or with being on the blizzard ui end. I tried using the gse macro reset in the options when this error occured and it didn’t correct it, but it did get corrected when i just /reloaded the ui entirely (which resets all macros).

I’m currently trying it with the $$/cast Crushing Blow recommended here by @TimothyLuke and I haven’t had any issues so far. If you’re using Crushing Blow and Raging Blow in the same macro block like you have in your pic above maybe you need to have $$/castsequence reset=combat Bloodthirst, Raging Blow as well so that the spellID won’t get messed up.

I took the castsequence out today and did a dungeon and it still broke… I actually did $$/cast Bloodthirst and still switched to Bloodbath as well, could be broken in gse?

What changes did you do to fix your issue? Ive tried the suggestion you have, it just breaks in the dungeon tbh. Solo play it works fine, even solo trash in a dungeon it works fine. It is only when i group up

Hey, so turns out mine does still break and it did so during a dungeon. I did some more digging, really gettin into the graveyards and I think i’m going to try the suggestions from this old post Hanging up · Issue #579 · TimothyLuke/GSE-Advanced-Macro-Compiler · GitHub. It suggests using /use instead of /cast as it behaves differently with spellIDs. I’ll test it out and see if its a solution.

Nice, i was looking through some old ones and prob annoying @TimothyLuke on discord… I will try /use for crushing blow… prob queue for a heroic instead of m+/0

Be careful with Use. In GSE it might replace your spell with a reference to a random item Id. Wow looks in items for an id then in spell for an if that matches what you put after /cast or /use. GSE treats these differently as there are conflicts. Ask Shamen about follower gear breaking spells of the same name in Legion.

GSE translates items and spells back to ids to enable cross language translation. /use gets converted to item ids while /cast and /castsequence get translated to spells. (If you put 10 for example in a cast it won’t be your item slot but Blizzard Rank 1)

The whole reason for the $$ was to bypass this but it may not be working. I’m in the car the next two days so need someone to raise this on GitHub so I look at it when I get back.

1 Like

Gave the /use Crushing Blow a whirl in dungeon and first time i didnt lock up… everytime before i locked

Sure thing. I would say $$ is definitely not working correctly as when I had $$/cast Bloodthirst it would still cast both bloodthirst and bloodbath. I’ve gone through two heroics so far without issue while using /use so I’ll keep going, but if $$ ever works as intended it’d give me peace of mind.