Darkmanz is back with a NEW DARKITTY all in one macro for 8.3

single target locks up like a 3 legged dog in a mud pit

**update- I resolved the issue

@oiciniv I was playing around and found a similar issue on my account that after playing with other builds and coming back to my normal build the thing just sits there and spams Thrash. Given the sequence of events that lead up to it doing this I became suspicious of the talent swap between Primal Wrath and Brutal Slash in the same session. I suspect that somewhere (either in GSE or in WoW) when Brutal Slash takes over for Swipe that variable is saved and then not cleared when we swap back . Logging out and back in cleared up the problem for me but I am looking to see if I can do something else to keep it from happening.

1 Like

Ok i give up, where is the macro?

@markdotjames, Sorry I had taken it down for a couple of hours as I found a hang in it. It is back up and running now.


For some reason every time I hit shift for aoe it cuts off the emote sound and i have to go back in and turn it back on does not do it on the single target one or if i run the aoe without hitting shift. Also got a error that said unknown macro 7/2

@shane-dolby Alrighty, a couple of things to address the first issue.

  1. Go into your ingame Keybinds and make sure that you do not have anything bound to Shift or any Shift modifier (also you may want to look for any Alt or Ctrl while you are at it as many macro writers frequently use all 3) Your pet binds is a good place to start, but for your problem specifically under the miscellaneous sub category there are some binds related to sound, I would advise unbinding any of the sound related stuff, unless you specifically use those bindings to adjust your ingame sound, and if you do…make sure that the previously mentioned modifiers are not used there.
  2. *edited to include:*I did a quick search to refresh my memory on the subject. Here is a reply from Timothy Luke on the subject: But the quick answer is in your /gs settings uncheck the "prevent sound errors (I’m sorry yes it is annoying hearing the error spam, but when chaining macros they fight each other and turn off your sound effects)
    GSE Pause / Wait: Stop Wasting Multi Charges Abilities - #5 by XamXan

Play with those settings and if the problem persists I can try to look into it deeper.

The second issue: the “unknown macro 7/2” conditional error. Thank you for bringing this to my attention, there was a typo in one of the conditions where I left a colon out. I have corrected it and uploaded a new copy. Please re-import or you can find the line:
/castsequence [talent:1/3, talent 7/2, notalent:6/2] reset=combat Rake, Moonfire, Thrash, Swipe, Shred, Ferocious Bite, Rake, Moonfire, Thrash, Swipe, Shred, Regrowth, Rip

and add a colon to the “talent 7/2” so it becomes talent:7/2

For some reason RIP is not firing off.

@Packsie You are going to have to give me more than that. What are the Talents? What are the circumstances? When is Rip not firing? ever? or sometimes etc.

I use the raid talents that u provided, and RIP is not going off at all.

@Packsie I just logged back over to my druid, set the “raid talents” up as I recommended, imported a fresh copy of the macro and ran it to make sure that it is working for me the way I intended… and it does. So let me go over a few things:

  1. If the Talent “Sabertooth” in row 1 talent 2 is selected (which in this case it is) it is intended that the macro will only cast Rip upon entering combat (after it builds a couple of combo points with a Rake and Shred or 2) and when a new target is selected. It will only cast the Rip that one time and it relies on Ferocious Bites to refresh it from that point forward. If you get separated from your target for so long that the Rip falls off, or your gear/haste/Click speed etc. is not quite enough to maintain Rip you can select a different target and then back to the intended target and the macro will apply a fresh round of Rip. You could manually cast a quick Rip, but I would advise against this as you may unintentionally “hang” the macro. (you may accidentally time it perfectly that the macro is looking to cast a spender in a sequence line and by manually applying the Rip you may take its points in which case you could always hit a quick Rake as well. But this should only need to be done on rare occasions, if it is consistently not keeping Rip up, then an adjustment is needed (in the macro)

  2. Click speed matters. I am running synapse with a very high click speed. The bulk of this macro and all of the checks that it does seems to like a faster pace (for me anyway). I’m running at 0.018 seconds (aprx. 60 clicks a second) I tested it at my slower click setup which is 0.10 (aprx. 10 clicks per second) and I found that it was sluggish. I think it should probably be ran at no less than 0.03 (or about 30 clicks per second).

All of this being said I watched it apply that initial (low CP Rip) and I started sweating as the timer was very close to expiring before the macro kicked a Ferocious Bite out and refreshed it. Once it is refreshed at a full timer it keeps up pretty easily. So I probably need to take a look at that first window and see if I can either give the initial Rip another CP, or get that first Ferocious Bite out faster to refresh it.

If you can please test to see if what I am telling you is what is happening to you (test it on some target dummies or something, you should see it apply Rip within the first few seconds, and I am guessing in your case it then expires before the first Ferocious Bite goes off to refresh it for you.

Yes it dose expire, my appologies <3 I use AHK cause i have no idea how to use synapse, my ahk is at 25, cause my ping is 24

This is one bad-ass macro - more to follow


@Packsie That is great news! It’s not entirely broke, it is just somewhat broke :stuck_out_tongue: You can try speeding up your AHK and see if it helps, Meanwhile I will put it back on the workbench and see if I can build us a larger window on that initial Rip without sacrificing damage. In the past I have built front loaded more combo point builders and lost some of the initial burst. But as it is I think the window is too small.

1 Like

Is this still workable to use as is til its repaired?

absolutely! The issue that Packsie is having is when talented into Sabertooth the Rip dot is expiring before Ferocious bite takes over refreshing it. If you experience the same thing you can simply swap targets (target yourself if its just one mob) then back and it should reapply a fresh Rip that should be refreshed by the next Bite. Or you can manually apply a Rip if it falls off.

Thanks Yea the unchecking sound errors in gse fixed it. I think its because it was calling another macro as it does not do it when you have the shift and commands in the same macro

Great Macro

in some of your lines you have nil, should it be nill? and nulll , should that be null?

@larry-dumas1 nil, nill, null, dfgdsdvs… etc none of it matters. they are all unknown commands, which is the intent. when the sequence hits an unknown command it freezes the line until a reset condition is met. So it does not matter what is in there as long as it is not a known command


Ok, I have reworked The entire thing so please update to the latest. I have added some options for you (and anyone else) with the Issue of Rip falling of when Sabertooth talent is selected. Please see the instructions. I would really really strongly emphasize that a higher click speed will probably resolve the issue for you, I tried slowing my click speed down to 0.1 clicks/sec and I was having issues with it falling off as well, not to mention the macro as a whole felt very sluggish. My Synapse is set at 0.18 clicks/sec

In regards to an earlier comment:

just wish the macro would hit regrowth more often

It casts Regrowth as often as it can (without popping out of form to hard cast it) at every MoC proc, unless you are talented into Bloodtalons, then it holds to use before a finisher to take advantage of that talent as intended.

1 Like

Can’t wait to give this a whirl m8 so tired of laser chicken