Demon God 8.3 Wreck Havoc Build - NEW CHAIN MACRO - Videos of macro in use included - July 2020 Update

So what azurite traits and essences are you using?

Added my raidbots sim to the post, it will show you all you need to know :slight_smile:

Because the author mentioned somewhere that he runs all his macros at 10.

His point is still valid though, how are you running it at 10ms, if you 10ms is too much for you adjust the way you are running it at 10ms to something different. you mentioned AHK, change your AHK script. Where did you get your script from, can you post it?

That doesn’t mean they automatically run at 10. They run at the speed that the macro keybind is pressed.

You said you are using AHK. Can you post a link to where you got the AHK script you are using?

July Update is a BIG DPS increase for me

it looks good but your macro makes my sound turn off. Idk why…

Ctrl + S turns off your sound

Happens to me when I use a CTRL mod on a macro and walk backwards :smiley:

Hey thanks for your answer, i expected something like that but i dont use modifier. The original macro of OP turn sound off as soon as i run it.
It has to do with /click DEMON_BITE
When i remove it, it works fine (even though i have not much fury since it doesnt click demon bite).

Do you have both macro’s imported? What MS do you run your Macros at, ,I run all mine at 10ms

Also no issues with sound turning off from my wow, so must be your key binding, also if your pressing ctlr + s that is nothing to do with the macro as there is no modifiers, again this is your key bindings

Ok i found out the issue from another post somewhere in the forum.


Feb 18

@XamXam - Short Version: if you are chaining macros you need to turn off the sound protection option in GSE as when chaining you are introducing a race condition that GSE has no control over

Long Version:
Now the thing to consider with chaining macros is that there is the problem of a race condition. A race condition is that something finishes after something else and has unintended consequences.

One of GSE’s options is to turn off the Error spam of “I dont have enough energy” etc. When you turn this function on what it does is add some code to your macro to take the current state (on or off) and store that, turn it off, run the macro, put back the initial state.

When you chain macros you have two macros doing that BUT the first macro doesnt wait for the second to complete so you get: get current state and save it, turn it off, call second macro, second macro overwrites that the current state is off, turns it off, first macro turns it back on and finishes, second macro executes, and turns off the sound as it started with sound off.

As neither macro knows about the other macro they compete. the best idea is to turn off error sounds and disable the option in GSE If you are planning to chain macros

1 Like

i tried your macro it stops cooldowns

Still my sound doesnt turn off so, I must have that stuff already done on my side

It stops Cooldowns? Like they never Cooldown? that is not the macro.

Anyways here is the old version


Hi i have imported both Macro’s to GSE where do i put the demon’s bite macro after importing it to GSE? Do I also drag it to the action bar or do i leave it in GSE? I have the Demon God Macro on action button 4 and i’m running logitech mouse software thanks for your time

you can just leave it in the GSE list, no need to add the demon bite macro to your bars

I tried the new version, its not working well, it has no resource to cast anything :c

1 Like

Did you import both Macros?

Solid macro man! I’ve been using another version that includes the heart essence and some alt/ctrl modifiers.
I went ahead and did a control test using my setup and getting a training dummy and then beating it down for 1m damage.
Though Details waits until no combat (maybe im just a newb) I would say yours with manually hitting essence and chaos etc without Meta = 10k improvement in DPS. So good on you sir!

1 Like