Did Blizzard break GSE?

All my macros are suddenly dead on all 3 of my PC that I had wow installed on, I thought maybe 1 glitched or had issues but no macros work on all 3 separate pc’s? I totally whipped one clean of wow, deleted folder and anything to do with wow, reinstalled everything and still nothing…

No problem here…Must be something at your end.

You might have better luck posting your problem in Tim’s GitHub page as he should see it there first.

It might be longer on here as he wasn’t tagged nor is this in the Troubleshooting section.

1 Like

I’m having the same issue, I’ve deleted the macros, deleted the interface, addon ,cache and wtf folders … reinstalled the GSE app from Curse > re downloaded a few macros from here to test… and getting nada… the macro cycles through the icons like it is working the rotation, but none of the spells fire off.

I tried rolling back GSE app to a version that was working on Friday of last week when I played, and the older version 3.1.35 is all so no longer working.

@joseph-geisler and @richard-w-lawrence post in here and Tim will get you a answer a lot faster.

Thanks, I posted the issues on the Github page.

Richard let me know if you figure out how to fix it and I will do the same, thanks

ActionButtonKeyDown or ActionButtonKeyUp and Why this matters Macro Cycling not firing · TimothyLuke/GSE-Advanced-Macro-Compiler Wiki · GitHub <— I am 99% convinced that that link has the answers to your problem


Not sure what caused it to change, everything was working fine until Monday, I have been using Bartender this whole time, but I turned it off and spent the time setting up the internal wow bars and the macros are now working again, so it is/was something in bartender for me.

Thank you for the reply Timothy.

Yep that was it, weird how it just broke Monday, thanks for the fix back up and running :grinning:

Bartender and ElvUI change the CVar setting whenever they wish. This is something you need to be aware of and act appropriately. The fix is to pay attention to what you are updating. This has been happening all expansion

It may have happened due to GSE updating. When GSE updated recently it broke all my macros and I just reverted to the previous GSE build.

Just checked it 5 minutes ago.


If you don’t mind my asking where exactly in Elvui do they set that? I’d like to double-check it so I can be more aware of when I have to troubleshoot in GSE.

When you login they Elv has a habit of changing it from Key Down to KeyUp or vice versa if they feel it’s needed based on your ElvUI configuration. It’s not something you have any control over they just do it. Also it’s keybindings which they reset again when they feel like it can interfere with using shift and alt for mod lines.