Elfyau's DF v1.4 Mistweaver Monk **Updated 17-May-24**

The macro has been updated and is now available in the original post and via Curseforge. Let me know what you think, Cheers!

Looks good, finished 18’s for everything with relative ease. I swapped out Veil of Pride for Shaoho’s lessons though and took Sheilun’s Gift out of the macro to cast manually.

1 Like

I tried a couple talent builds from wowhead, but not much happens when I run the macro. Do you have an updated talent build that works, please?

the talent code he put in it 2 days ago for the update works fine for me.

@Ole_1738 as @Siodar pointed out I have recently updated the post and macro, grab the talent string from the post or the macro itself

Copied the string from the first post in this thread and that imported successfully. So then I tried the string in the macro again and it said out of date. So I deleted all the macros and reinstalled in zygor. But the macros weren’t in GSE after reloading. Exited and restarted, still no. So I copied the macro strings from your post here and manually imported. Then I copied the strings from the freshly imported macros and that worked. I’m probably doing something wrong though. It’s working now though. Thank you for maintaining these! Been using your macros for years.

1 Like

Doesnt work for me? Starting with Touch of Death, can spam it like i want, it wont pass or even start going in the seperated sequences? : /

Usually means wrong talent build. Try this:

ok ty works now so far, but normal that faeline stomp gets castet that late after anything else? ?
does v2 still excist i overwrote it sadly

MVM now im good :smiley:

also following for a answer it takes a long long time for it to be cast and then there’s no spinning crane kick in nearly the entire time stomp is active aka missing out on upwards of 80% of ancient teaching potential heals is crazy

@murphdh @Fask Ty for the feedback I will look into this on the nest update

no problem buddy thanks for the quick response your healing macro is perfect out the box but yeah honestly the dps one needs to be focused more around the stomp and spinning crane kick just as much as the single target stuff

1 Like


in my personal experience, this is how i usually proceed to get the best possible distribution of enveloping crap.

chiji pet up → call action list Chiji Rotation

Chiji Rotation

  1. Renewing mist if will reach 2 charges
  2. if ancient teachings falling off, use thunder focus tea (for refresh via essence font)
  3. if ancient teachings falling off, refresh with essence font (even if you were unable to focus tea)
  4. if you can’t use essence font for some reason, use jadefire/faeline stomp to refresh instead
  5. At 2 stacks of Invoke Chi-Ji, the Red Crane, cast Enveloping mist
  6. Rising Sun Kick
  7. Spinning Crane Kick if (target >=2 & !talent.ancient_concord & !talent awakened_jadefire) | (target >= 4)
  8. Blackout Kick
  9. Tiger Palm

i personally would try to get the macro working up to two stacks to cast enveloping mist on 2-3 people, and starting with stomp, i think would be the best effort of it then :stuck_out_tongue:

1 Like

The link on Curseforge: The link at the bottom takes you to the
Elfyau’s (GSE 3) 9.2.5 Mistweaver Monk Macro Updated 15-Aug-22. I didn’t know if this was up to date or the wrong one… Keeping your game tight.
I am learning and really digging your macs. Using your macs to level up a monk painfully as a mistweaver. Everyone told me not to because it takes to long but it has it benefits… lol I have been trying to edit yours to fit my needs. Level 58. it’s taken a week to get there but who care I am learning…
Thank you
If you got a lvling macro let me know, I will test and use it.

1 Like

Talents are out of date

copy the talent code to Wowhead and it should give you a up to date code.

The talent string has been fixed and is available in the original post and via both the Wago and Curseforge app. Let me know what you think, Cheers!

1 Like

Hi Guys, I have an odd thing happening. When I use the macro, on CD it pops Thunder focus tea, but I cannot see it in the macro. Am I missing something?

Does this happen to anyone else?


The macro has been updated and is available in the original post and via both the Wago and Curseforge app. Let me know what you think, Cheers!

1 Like

<3 Thx for the update!!!

1 Like