ELVUI+GSE3 Interface wont load problem

Actually love the new GSE3, however unless I disable the Elvui Addon I cannot load the user interface for GSE3.

The GSE3 Macros do still work I just cant edit them or do anything.
Have tried a total clean slate with wtf deleted and same result.

Message: Interface\AddOns\GSE_GUI\Viewer.lua:143: attempt to call method ‘SetBackdrop’ (a nil value)
Time: Fri Jul 9 15:08:14 2021
Count: 1
Stack: Interface\AddOns\GSE_GUI\Viewer.lua:143: attempt to call method ‘SetBackdrop’ (a nil value)
[string “@Interface\AddOns\GSE\API\Events.lua”]:417: in function ?' [string "@Interface\AddOns\Ace3\AceConsole-3.0\AceConsole-3.0.lua"]:94: in function ?’
[string “@Interface\FrameXML\ChatFrame.lua”]:4825: in function ChatEdit_ParseText' [string "@Interface\FrameXML\ChatFrame.lua"]:4488: in function ChatEdit_SendText’
[string “@Interface\FrameXML\ChatFrame.lua”]:4524: in function <Interface\FrameXML\ChatFrame.lua:4520>
[string “=[C]”]: in function `ChatEdit_OnEnterPressed’
[string “:OnEnterPressed"]:1: in function <[string ":OnEnterPressed”]:1>

Locals: self = {
ResetButtons = defined @Interface\AddOns\GSE\API\Storage.lua:473
StartOOCTimer = defined @Interface\AddOns\GSE\API\Events.lua:440
ReportTargetProtection = defined @Interface\AddOns\GSE\API\Options.lua:884
RequestSequence = defined @Interface\AddOns\GSE\API\Serialisation.lua:313
CloneSequence = defined @Interface\AddOns\GSE\API\Storage.lua:38
modules =

CancelTimer = defined @Interface\AddOns\Ace3\AceTimer-3.0\AceTimer-3.0.lua:147
CheckOOCQueueStatus = defined @Interface\AddOns\GSE\API\Events.lua:501
StopOOCTimer = defined @Interface\AddOns\GSE\API\Events.lua:445
GUIImportSequence = defined @Interface\AddOns\GSE_GUI\Import.lua:76
inArena = false
GUIRecordFrame =
GUISetColour = defined @Interface\AddOns\GSE_GUI\GUIFunctions.lua:165
GUIConfirmDeleteSequence = defined @Interface\AddOns\GSE_GUI\GUIFunctions.lua:19
inDungeon = true
UsedSequences =
ScheduleTimer = defined @Interface\AddOns\Ace3\AceTimer-3.0\AceTimer-3.0.lua:94
UnsavedOptions =
UpdateIcon = defined @Interface\AddOns\GSE\API\Storage.lua:770
ADDON_LOADED = defined @Interface\AddOns\GSE\API\Events.lua:144
SendSequenceMeta = defined @Interface\AddOns\GSE\API\Serialisation.lua:296
UpdateSequence = defined @Interface\AddOns\GSE\API\Storage.lua:485
UnregisterAllComm = defined @Interface\AddOns\Ace3\CallbackHandler-1.0\CallbackHandler-1.0.lua:174
SetEnabledState = defined @Interface\AddOns\Ace3\AceAddon-3.0\AceAddon-3.0.lua:424
isSpecIDForCurrentClass = defined @Interface\AddOns\GSE\API\CharacterFunctions.lua:87
ClearTooltip = defined @Interface\AddOns\GSE_GUI\GUIFunctions.lua:197
TranslatorAvailable = true
IdentifySpells = defined @Interface\AddOns\GSE\API\Translator.lua:427
TransmitSequence = defined @Interface\AddOns\GSE\API\Serialisation.lua:235
storeSender = defined @Interface\AddOns\GSE\API\Serialisation.lua:334
NewModule = defined @Interface\AddOns\Ace3\AceAddon-3.0\AceAddon-3.0.lua:235
prepareTooltipOOCLine = defined @Interface\AddOns\GSE\API\Events.lua:485
GetOptionsTable = defined @Interface\AddOns\GSE\API\Options.lua:6
OOCPerformMergeAction = defined @Interface\AddOns\GSE\API\Storage.lua:155
RequestSequenceList = defined @Interface\AddOns\GSE\API\Serialisation.lua:357
Deserialize = defined @Interface\AddOns\Ace3\AceSerializer-3.0\AceSerializer-3.0.lua:246
ReplaceMacro = defined @Interface\AddOns\GSE\API\Storage.lua:227
TranslatorLanguageTables =
GetSequenceSummary = defined @Interface\AddOns\GSE\API\Storage.lua:1082
DeleteSequence = defined @Interface\AddOns\GSE\API\Storage.lua:9
name = “GSE”
StripControlandExtendedCodes = defined @Interface\AddOns\GSE\API\StringFunctions.lua:151
Disable = defined @Interface\AddOns\Ace3\AceAddon-3.0\AceAddon-3.0.lua:314
GUIImportFrame =

This is not the place to report errors.

Register, and open an issue to timothy


What a warm welcome to the “GSE: Troubleshooting]”.

Hi Tiny.

If you post a bug report on Github, don’t delete the default BUG Template. Use it.
Edit paragraphs with your informations (give steps, details about your GSE version, provide your GSE.lua file, etc…)

This might help Timothy help you.

Thanks will do, figured ask the community before bothering the dev who will already be busy as.

There is an option in GSE’s options called fix backdrop or something. Elv changes a ton of stuff for Ace3 based mods of which GSE is. Unfortunately it doesn’t play well with Ace3 as a whole and breaks a lot of stuff. There are some UI setups that this occurs for which without your entire UI and mod config I can’t solve so there is the option to try to fix it.

Alternatively you. An go to ElvUI - Skins and turn off Ace3.

i havent had this issue with my Evlui and the GSE.

@Siodar i love you but this is the most useless post ever. Do you really want to experience every quirk and glitch that everyone else encounters? If so I can give you a special version of GSE where things randomly dont work.