Failing to get GS to work please help

So I have tried for about 3 hours and watched multiple videos before posting.

I loaded the regular version of GS not the enhanced

I renamed the file Sequences.lua

inside that folder all i have so far is;

local _, Sequences = … – Don’t touch this

Sequences[‘RetST’] = {
PreMacro = [[
/targetenemy [noharm][dead]
‘/cast Judgment’,
‘/cast Crusader Strike’,
‘/cast Exorcism’,
‘/cast !Avenging Wrath’,
‘/cast !Execution Sentence’,
“/cast Templar’s Verdict” ,
‘/cast Hammer of Wrath’,
PostMacro = [[
/use [combat]13
/use [combat]14

I then go into wow and create new macro for RetST but when i click okay it does nothing. On videos i watched once you hit okay it brings up #showtooltip /click (macroname) but I do not get that. Please help I really don’t want to have sinked this much time into nothing :frowning:

The tree dir should be exactly like this ( only 3 files in folder ) , and the entire folder goes on Interface\AddOns.

GnomeSequencer < Core.lua Sequences.lua GnomeSequencer.toc

You will be editing all the time ONLY sequences.lua

The first line inside is like you said local _, Sequences = … – Don't touch this

Then you put your macro with no syntaxis errors


Sequences['shadowdot'] = {
PreMacro = [[
/targetenemy [noharm][dead]
	'/cast Shadow Word: Pain',
	'/cast Vampiric Touch',
PostMacro = [[
/cast crystal of insanity

And finishing, you just create a macro ( not in general tab ), with the name shadowdot ( drop that macro to bar and MASH THE BUTTON ).

Hope that helps.

Yessir I double checked everything and also copied several macros from the forums here and none work. Also trying the macros one at a time to make sure its not one ruining everything else … not sure what else to do at this point

If your using v4 of GS you need to change the first line from
local _, Sequences = …
local GNOME, Sequences = …

Using version 5 just downloaded from wow interface today. Anyone else got any ideas really upset cause I have been looking for something like this for years since they killed the old macros.

Then you need to change that line.

it wont work with the local _, Sequencers = … it needs to be local GNOME, Sequencers = …

Alternatively your macro will just drop straight into GS-E (That specific macro is a part of the 0.2 build of GS-E that works with 6.2.4)

Don’t forget…ya gotta turn on GnomeSequencer in your Addons tab and reload your UI inside the game itself. THEN make your GS macros and GG…