-FIXED- Yet Again, Mods don't Work

Just so you don’t have this happen as well, it wasn’t enough for me to select “none” as a key in “lock action bar” I had to untick it, and that gave me all my modifiers and Shift to work.

I’ve read every single “modifier issue” post here that I could, and tried everything that was suggested in them.

cleared EVERYTHING from keybinds except Z / X
to make sure nothing else was pressing shift/ctr/alt+Z/x

I even went so far as to PURGE my wow folder, every single possible config related to accounts or addons, and after that didnt work, I deleted my entire wow folder, reinstalled the game, and installed only GSE.

Mod:Shift Never works.
Mod:alt is bipolar ? decides if it will or wont work
mod:ctrl Rarely works

Also ,macros that have ST/AOE in seperate macros and call for the other macro to be clicked with a mod, never gotten to work since pre-shadowlands.

I’m all out of ideas, I just don’t know anymore, what else could it possibly be if not related to addons/ingame configs?

I’m starting to pull out my hair…

Any ideas appreciated…

I know this may sound dumb. but what keyboard do you have. My wife years ago couldnt strafe with mouse and keyboard and after much time looking into it, i found some keyboards cant have more then one key pressed at a time.

Sounds like you tried everything so this is probably redundant, but did you make sure that your action bars aren’t locked with a modifier? (either Blizzard’s own settings or through a third-party addon) I have to turn off the option to use SHIFT to move buttons around otherwise it never works as a mod for me in GSE.

Hello @AsmodeusCruentus,

I’m sure you may have done this already.

Did you click that GSE setting for the keybinds?

Or check with this if the keys lit up properly:

It is a Razer Blackwidow Chroma AKA gaming keyboard with no limitations to key presses, All modifiers used to work for me prior to shadowlands
Maybe it stopped late in BFA, but i didnt notice until Shadowlands where i used macros with more than 2 modifiers

Yes, I tried this aswell, As Stated I removed EVERY single keybind, and that includes disabled lock actionbars, self cast, even loot key >_<

That keyboard tester is kind of flawed, pressing ALT bring me to the top left menu file on the browser, but yes, clicking the keybind didnt work either

@Foo @lutechi @jonnyfi71

I came home, sat at the computer, and double checked everything, lock action bar is none but ticket…
Lock Action Bar Is None But Ticket…LOCK ACTION BAR IS NONE BUT TICKET!!!

Apparently that isn’t good enough, unticking it made shift work what the actual Hell is this game x)

I appreciate you all for questioning the basics to make me triple quadruple check everything, this feels like a dumb design, If the actionbar is set to have “none” key to unlock the bar, it shouldnt block the default key by default, God damnit…

Lutechi, maybe you can put it somewhere incase others have this issue, that selecting none isnt enough and it must be unticked.
Btw, Love your AIO macros <3

1 Like

Glad it worked out for you - yeah I forgot to mention that, setting it to NONE by itself is only half the solution, disabling it completely along with setting it to NONE seems to be the requirement. I hope this gets resolved some day because it’s driven many people crazy.

1 Like