GSE 2 Rollback Link

For those having issues with 3.0, i managed to roll my install back to version 2.

You need to uninstall the current version, and manually install the one from here: https://github.com/TimothyLuke/GnomeSequencer-Enhanced/releases/tag/2.6.55

Just download and extract GSE-2.6.55.zip to you mods folder.

I dont know why its causing so much trouble, and why you would choose to roll it out on patch day, but for now, imma stick with 2.6.55.

4 Likes

I’ve created an account just to thank you for this post. There’s probably a good reason for GSE.3 but being lost, I’ll use old version as long as possible.

3 Likes

Learn to use GSE 3
Sure older versions will work for a while but eventually will break as WoW updates over time.

It takes less then 10 mins to learn how to use the new and improved GSE 3

3 Likes

Version 3 was a bit daunting for me at the start. But really as soon as you get your head around each action is a block, it’s sweet. Thank you @TimothyLuke

With the latest V3 for Classic TBC I did need to recreate all my macros as none were “imported/converted”.

Small price to pay for such a great application.

1 Like

yea i tried to understand it but just no chance im noob with this stuffs is ther s guide video i cant watch cant read very well.

also my addons saying missing gs-core but i cant find that either

No it is not. About all my macro that had “castsequence” in them get corrupt and not working anymore. I can see why Timothy want to move to GSE3 as it give more control over spell order yet with this abysmall interface it is hard to even find where your loops starts and where next ends.

1 Like

I’m sorry but it works just fine (except the latest bug of the editor disappearing, but thats unrelated)
Your issue is user error over not understanding how it works. Not all imports are working, but it only takes a minute to fix them. Again take the time to learn the the new update and correct your macros.

2 Likes

learn. Learn. LEARN.
Don’t be lazy and expect others to fix them for you. Expand your mind.

1 Like

As i said - i have no issue of understanding how my macro works - i can rewrite it manually in loop instead of castsequence as import convert them into banana jam - but instead of looking into code i scroll up and down looking for where one loop start and then other ends. Its awful user experience and very confusing. As for those who do not programming much it result in just one solution - revert back to GSE2 while it still working.

1 Like

It has nothing to do with coding. by the that argument the old way would be more confusing for the average person. the new flow al tho clunky and unfinished, flows much better. especially once he adds drag and drop functionality to it.

Either way it functions EXACTLY as GSE 2 did and boils down to ‘people don’t like change’, user error, and user ignorance. To each their own tho your entitled to your opinion.

Castsequence works just fine in GSE 3.0.07
unless its bugging out on you as some have castsequence issues ingeneral due to blizzard (unrelated to GSE) Personaly I dont so Ive never expierienced that but know it happens.

Old way are works exactly as blizzard macro, so it in no way more confusing as it is in GSE3.

Old sequences worked like charm prior to 9.1 but, yes, they could scramble as blizz done something with it on their side. As for now i have rewrited my macro on warrior and it took me way more then 10 minutes, and with cold chills looking into restosham macro that was working flawlessly before.

So the take-a-way is you now know how to use it.
Congratz.
My bad on the 10 minutes comment, everyone learns differently. who-da-thunk-it

You miss what i was pointing to.
As it is now GSE3 provides a awful user experience, when instead of coding user have to look into block order. If user have never coded before and in import phase his 9.0-working-macro get broken - in no way in 10 on 20 or even 37834 minutes he can do something that he never done before. What he get when he jump into typing /gse and clicking macros name? Blocks with tildas in it and no sequence structure that he seen while he was imported macro (or even copied some wiki macro into blizzard macro tab) before.
As result to this user there only one option - return to GSE2 as it was working.

Opinion

its vertical now rather then horizontal

If they never done it before they need to take the time to read and LEARN how to. I believe that was my first suggestion…

and as its no longer supported it will eventually break. its like putting a bandaid on a wound that needs stitches.

Nothing you stated above changes the fact that the user, ANY user, new or old to GSE, needs to take 10 minutes and LEARN how to create, use, and edit macros using GSE 3. So far you oly been stating opinion and frustration at my answer due to simply not liking it.

Fun fact ~~ variables ~~ have been in GSE for a while now, and for the same reason its confusing to anyone now, it was then, because they didnt learn how to use them. with GSE 3 your FORCED to use them, they replace the need for pre and post macro boxes all together and make the entire macro creation LESS steps. Variables is NOT coding and each individual line ‘/cast blah’ or ‘/castsequence blah, blah’ is entered, used and functions EXACTLY as it did in GSE 2 with only 2 differences. 1. your forced to use variables for pre and post, and 2. your reading and working vertically and not horizontally. Its not difficult.

Adapt to change, dont hate change.

1 Like

Opinion, indeed. And in my opinion GSE3 not ready and experience with doing macro in it are not to my liking. In some time everyone have to move to GSE3 or drop using GSE as Timothy stated that he was not supported GSE2 for 6 month already and have no intention to support it.
As of now those who do not like how GSE was change have option to revert to GSE2 as it still works. For now it is way more usable in my opinion than fight with interface as it is in GSE3.

Pure Bullshit, Some of my macros are just not working in the maw but anywhere else. No logical explanation for that on my side. with gse working fine there, dunno how that is even possible but have this issue with multiple macros

And i agree that its much more complicated for new users, as i started writing macros for myself in gse it took me like 2 minutes to get started because its almost 1:1 the macro interface from Blizz

Opinion for sure but a widely held one. I just made an account to chime in here.

There is quite a big major UI issue here not to mention learning curve…and then right when the patch dropped. Its not about not wanting to change or not wanting to adapt, its about the timing, the learning curve and the upgrade process to not break existing macros.

I heard that the developer builds according to the desires of his patrons which makes sense but at the same time, give me a way to pay a fee built into it and I would gladly pay. TradeSkillMaster does this with their desktop app so it is possible to do.

1 Like

this is against bliz TOS

OK, maybe I’m missing something, but for me the biggest issue is that there is no way to run GSE2 and 3 at the same time. As someone who uses these macros for multiple characters, I have GSE2 macros and no idea when (or if) they will be updated. I’m a macro user, not an author and I don’t want to update someone else’s macro when they may very well be working on it at the same time.

I wish this would have been issued as a new add-on which could be run at the same time (or used GSE2 for one character and GSE3 for another).