[GSE 3.0] Xinterp's 9.1 UH-DK ST/AoE PVE - 2 Macros - Updated: 6/30/2021


If you use this macro, please be sure to like the post so I know it helped you!

I run this @85ms.

These macros should handle casting Outbreak for you. No need to manually apply anymore! :slight_smile:

Festering Strike and Apocalypse will need to be on your bar for manual use when needed for Burst Situations. You will also need the standard Raise Dead, Army of the Dead, and Mind Freeze for manual use as normal.

Asphyxiate is Mod Alt.
Festering Strike is Mod Ctrl.


These macros are VERY prone to Rune Starvation. Please be mindful that you may come in to dry spells at some point. This is normal with most UH-DK’s.
Be mindful of this when you need to cast Apocalypse. You’ll want 4 stacks of Festering Wound before casting for the best results.


Weakauras that I use for these Macros (Click for link to WAGO.IO).


Single Target:



Talents: 2131223

This macro contains 1 macro template. This Sequence was exported from GSE 3.0.1.
Big thanks to @jackwells92 for helping me find the fix for this!




Talents: 2233232

This macro contains 1 macro template. This Sequence was exported from GSE 3.0.1.


6/30/2021 - Updated version to fit GSE 3.0 and WoW 9.1

If you have any suggestions on how I can make this better, please let me know!
The macros here have not been uploaded as “Read Only”.
If you feel something needs to be changed, please make the changes and let me know the results so I can modify what is posted!

Thank you!

Thank you!


Hi mate!

Your ST macro works perfect for me.
I only modified it a bit for my playstyle (mod keys and so on…)
The MT macro is not very useful for me, no festering strike.

THX for the ST macro.

I’m glad it worked for you!

TL:DR at the bottom if you want to skip this mumbo-jumbo.

For the MT macro, I have Festering Strike on the bar.
I use Festering Strike to build, setting up 5/6 stacks, then use the MT macro for the burst AoE you can get.

The problem I ran into was rune management.
The Festering Strike wouldn’t happen when it was needed for re-application because of the Scourge Strike only taking 1 Rune. Since GSE skips and doesn’t wait at the next step, we’ve ran into the problem of it skipping a Festering and moving onto a Scourge.

Say we have 3 Runes.
1, 2, a, and 4 cost 1 rune, and b costs 4 runes.
In the sequence below, b would get skipped.

(b), a, a

Since b got skipped, next time around, a would be used instead of b since it got skipped.
We also need to look at the other abilities that are 1, 2, and 4, that are using runes, leaving b with a chance to almost never get cast on its own.

IF GSE found a way to make “null” run for one step without breaking an entire sequence, we could add pauses into our rotation for one GCD, but this hasn’t happened yet, so Unholy can’t quite be fully 1 button and be extremely efficient.

We also have the “RNG” aspect of Festering Strike either giving 2 or 3 stacks of Festering Wound. This can’t quite be accounted for since GSE can’t operate based on arguments. If GSE could operate based on arguments (Example: “if [debuff: Festering Wound{spell=194310} = 4/5/6], then if [debuff: Death and Decay{spell=43265} = Active], then if [debuff: Virulent Plague{spell=191587} = Active], cast: Scourge Strike{spell=55090}”) then we would be in business for a “Perfect” macro.

All of that is subjective though.

I don’t have it in the AoE rotation because it’s repetitive casts were unreliable and didn’t provide consistent results. It either almost never cast, or it casted too often, hence the reason for manual casting Festering Strike.

That’s a beast of a macro! The ST is sublime, it fits perfectly with the sim dps, which is great.
By far the best Unh gs macro at the moment.

To answer what you mentioned about the gse skipping sequences, what about the click pauses? We could build something calculating the right ms and apply the correct click pause to help gse avoiding skipping important spells such as festering.

I also have a quick question. When you talk about running at @85ms do you also take in the account the realm latency? do we have to include the world’s ms in it or do we add the ms world afterwards?
To be more specific, usually if a macro runs at 50ms I run it at 100ms (50 for the gs macro + 50 for the ms world). Is that somehow a mistake or it’s a good thing to do?

In all reality, it doesn’t matter how fast you run it. World latency isn’t calculated into the ms at all.

On posts here, the ms is just a suggestion for the results the creator gets. It doesn’t factor into gear, stats, latency, etc…

If you’re getting good results at 100ms, roll with it! Make sure you’re having fun!

Updated this macro.
Please let me know if there’s anything I can improve on.

Help is ALWAYS welcome!

Thanks all!


Updated version for GSE 3.0/WoW 9.1
If anything isn’t working, please let me know asap and I’ll fix it if I can!

not working for me nothing firing off and says unknown macro option c all the time

I think some text may have gotten changed when importing the macro.
Can you look for anything that’s got an argument in it?

“/cast [c] InsertSpellNameHere”
“/targetenemy [c]”
This would cause the issue you’re having.

I have re-posted the macro just to be sure I didn’t fat finger something by accident.

ill try your reimport then check, this new gse looks confusing when I open the macros lol

same issue after casting dark transformation does nothing for me, gone through the macro cant see any issue with spellings etc its only your ST one for me, the MT one works fine

Noted. Looking into this now. I’ll find the cuplrit. :bomb:

Ive scoured your spellings in the macro etc cannot for the life of me find it or what it could be lol good luck bro!

Give it a whirl now.

still the same, it has heart strike in now to? I think I found the culprit of the original ST macro, I think its the repeat type? your mt macro has repeat 3 in where as st has repeat 1?

Repeat isn’t the issue.
I noticed Heart Strike as well after GSE swapped over.
I’m unsure as to why. Looking into this.

Ill have a play around as well I’m just sat at the dummy trying to get my fav macros working again :slight_smile:

You were right.
Loop limit resolved it.

I changed loop limit to match the 9 spell castsequence.

Let me know how that works!

Woooo i had a feeling it could of been that! I just wasn’t sure on the correct number. So basically that jumper should be the amount of spells that are in the macro or have I misunderstood?

Not necessarily. I think as long as it has a castsequence in it, it needs to have a loop.
I’m unsure if loop counter makes a difference past 2, but I did 9 just in case since that matched what you’re thinking.
2 appears to work just fine as well, but when I drop it back to 1, I get the previous issue we had.