GSE Cycling but not casting

any idea of a work around in the mean time? I use a naga with 1-12 key buttons so my thumb does my clicking not mouse clicking, so my macros are the 1 and 2 button

Its really odd as it works on the Beta just fine.

There is a difference somewhere I can assure you.

So for me I have my GSE macro always on my 1 or 2 keybinds usually both 1 is single target and 2 is usually aoe. Left clicking on them has also worked in the past, but I dont use my mouse to click them in game. I use the 1 and 2 buttons, my naga mouse has 1 through 12 keys that by default are 1 through = on my keyboard. Those and left clicking the macro on the keybind do not work, but right clicking the macro on the keybind is the only thing that works.

I am scrolling through the gse options to see if I can find a work around, but for now I am stumped.

Anyone familiar with the GSE addon know any details or insights as to what could have caused this change or a work around option would be greatly appreciated.

1 Like

this for me. i see spells cycle in macro but nothing casts.

1 Like

isniss i do the same thing. i found something that works. goto your /macros and goto your specific macros.

find your macro for your 1 key and it should say something like this. this is from mt bm hunter

#showtooltip
/click [button:2] BMSOLO RightButton; [button:3] BMSOLO MiddleButton; [button:4] BMSOLO Button4; [button:5] BMSOLO Button5; BMSOLO

all i did was change that button:2 to a 1 and it worked just frine for me. i dont know if all macros are like that. but thats what mine did and how i fixed mine

9 Likes

You are a freaking genius mate! TYVM! WORKS PERFECTLY!

Are you talking in GSE or in Blizzards macros?

That worked thanks.

Just wanted to add here that I use a controller and was having a similar problem. opening the macro in the /macro window and changing [button:2] to [nobutton:1] made the macro start working.

worked like a charm for me. thank you!!!

unfortunately, this workaround didn’t work for me. still have the cycling without casting. but, now even teh right mouse button won’t cast.

Same, I tried the workaround, and nada. It is still cycling the spells, but not casting them.

there is no point in trying to modify the macros. it is a problem of the addon. they will fix it

I think you need to do some reset inside the addon “GSE UI” … this what I did and it worked for me … give it a try

type /gse and press enter … once the GSE UI opened press on “Options” and go to “Macro Reset” from the left side panel, 3rd one … then press on “Clear Keybindings” on the top page … then press on “Update Macro Stubs” the last button on the same page … and finally press on “Close” and “Close” again and try to fire your gse macro and enjoy :slight_smile:

3 Likes

Yep, this worked (the change Button 2 to 1). Also there is a reply from Tim and others on the GitHub page. Seems this is a Blizzard bug that was fixed in Beta but not carried over. But this work around is easy to apply so problem solved for now!

2 Likes

This! This worked perfectly for me! Thank you!

Had the same issue, make sure after you change the stub macro you hit save. The first time I tried it, it didn’t work because I didn’t save the stub after I changed it.

It worked for me, but i can’t use modificators on the main wow macro or it stops working again.

Like:
#showtooltip
/click [nomod] GSE macro
/cast [mod:alt] Spell 1
/cast [mod:shift] Spell 2

I think you might want to bind them again … while in game press “Esc” … “Options” … “Game” tab from the top left corner … Under “GamePlay” you should see “Keybindings” … from there you can assign the keys again …

There is a new update and TymothyLuke said
NTOE: macro stubs need to be deleter and “Create Icon” again

which I took to mean
NOTE: macro stubs need to be deleted and “Create Icon” again

1 Like