GSE - Import Issue and button unresponsive.

Hello there lovely people.

So I am going to try to be as descriptive as I can to try and explain the issue with this add-on and how it relates to my current angst!!!

First off this is what I did.

1 - Fresh install of GSE through twitch add-on installer.
2 - Started the game “would you like to import default macros?” to which I said yes (lovely so far).
3 - Copied the text of my desired macro ensuring that all the syntax was correct <<<not computer illiterate :smiley:
4 - Opened up GSE by typing /gs in chat and low and behold up it pops.
5 - Clicked the little import button (you still with me?) and pasted the entirety of the macro, yey.
6 - Once again clicked import, followed by close and nothing…no macro, so scratching my already aching head I closed the add-on and re-opened it using the slash command and low and behold there was my wee macro smiling back at me.
7 - So went to add another macro (AoE type :D) copied pasted etc and hit import. Was rewarded with the message import complete so I hit close once again but guess what??? No macro!!!
8 - Closed it down and re-opened the add-on again like I did previously but still no second macro >(
9 - I checked the GSE.LUA and the first macro was there but still no second macro. Remember also, this was a clean install, so no other macros exist…what a conundrum huh?

I have no idea what is happening and too add insult to injury ever now and again but more often than not, the AHK script just stops. Now I know what your thinking, maybe its AHK fault but nope cos when I click out of wow and press the key the wee key works absolutely fine, even if I hit return the chat window fills up with 11111111111111 lol.

So anyone…what the hell is going on???

Love and peace

There is a delay from when you press save to when the action occurs. This is because it queues up the change and then waits for a number of conditions to pass including being out of combat. Once that change has occured it will then repopup the GSE window. You can review the queue by looking at the LDB panel.