GSE Is rewritting conditions/spell: !Stealth to Stealth

I use my combat log to troubleshoot my macros and noticed the number 1 spell thats filling up my log is stealth.
I’m trying to polish up my macro so my combat log stays clean, cleaning up all the spamming it does when it shouldn’t, like spamming stealth while its in combat and filling my combat log with stealth failed

the following fixes any stealth braking but continues to fill up my combat log
/cast !Stealth
the following macro works and tested it using wows macro tool, Stealth will only be casted out of combat, will not break stealth and doesnt show up in the combat log during combat [because of the condition]
/cast [nocombat] !Stealth
the following macro is the re-written version of the above macro by GSE after saving it to my rotation in any of the locations[keypress/keyrelease/pre/sequence/post] and will cast stealth out of combat but will break stealth because the " ! " gets deleted
/cast [nocombat] Stealth

this is important to me because the combat log is the only way i can trouble shoot/verify what my macro is actually doing so keeping it clean is a priority, so my question is why is my macro being rewritten by GSE and how can I stop it/prevent it/fix it

bump

I had the same problem and i also tried all the version above. None worked for me with GSE. I end up by using a two key macro (key A = macro, key B = a ingame macro like /cast [nocombat] !Stealth
So i just need to push one key and it looks like BAAAAAAAAB…

yeah thats a work around, it seems like we found a bug

I am back to the game, playing my rogue. I am still facing the problem that “Newklear” explained above, with the exception that Stealth only work when i click a friendly target and than start the macro.
My “solution” with a two key macro seems to give me lower DPS. So any ideas how to fix this will be much welcome :slight_smile:

Sorry for pushing this thread, but i still have this problem. If someone knows a fix please let me know.