GSE not firing spells

I’ve used GSE for years since the 1st version. It’s worked fine till this new wow update. I’m using the latest version of GSE and haven’t changed anything but now my macro just goes thru the icons but doesn’t actually cast the spells. It just auto attacks…I use a Razer Naga for my macro but like i said it’s been the same for years and worked fine until now. Any ideas?

Ok so I tried an older toon using an older macro and it works fine still. I didn’t make this post until trying 3 different NEW macros for dragonflight on 2 different classes and it doesn’t work. What am I doing wrong lol? I tried the more popular new ones that seem to work for others. I setup the new ones even using their spec import to make sure it should work as intended too.

Sounds like you are in KeyUp mode but have GSE configured to KeyDown. The detail about this is located at ActionButtonKeyDown or ActionButtonKeyUp and Why this matters Macro Cycling not firing · TimothyLuke/GSE-Advanced-Macro-Compiler Wiki · GitHub

In GSE’s options thenTroubleshooting tab will let you change to either up or down and if you use the force option - that will reconfigure GSE to be either up or down

1 Like

thank you for this info! i am in keyup mode actually but never had a problem before trying the newer macros. i’ll try the force option :slight_smile:

OMG my gse was working fine & next day is wasnt I was going crazy uninstalled wow & reinstalled & still gse wasnt firing lol TY ! I hate this new stupid UI blizz added…

Do you have any idea why mine might still not be working? I’ve done all the tips. Went to troubleshooting, reset stubs, I have the box checked and the keypress set to down. It’s still just cycling and not doing anything. I also have it checked in AdvancedInterfaceOptions and I also ran the console script to make it keypress down.

@Aaron_Brown I don’t know either mine also doesn’t work - never has with any of the suggestions. For mine I have had to change:
image

button:1 to nobutton:1 then mine works fine

I was having the same issue. Just for giggles, I unchecked ActionButtonUseKeyDown and Set the Force CVar State to KeyUp. Now everything works. Forgot one thing. I pressed the update macro stubs right before doing all of that.

1 Like

Hm, that doesn’t seem to do anything either. How am I supposed to Raid?! lol
Capture

1 Like

You either need to force from GSE’s option KeyUp or KeyDown mode. You can’t have a mix and match like you are trying if you want things to work. WoW has changed and these strings need to be extremely specific and are different depending on the mode you, or your Other addons have placed you in.

1 Like

Ive tried a few times now to see if the KeyRelease commands that everyone puts in their macros works and no only the KeyPress commands seem to work for Lines like this. Because of the new WoW key rules will this not work again?
KeyPress
/cast [nochanneling] Kill Shot
KeyRelease

No this is because of the rules.

Those three lines combine into one action. That action is evaluated from the top down and the first GCD ability that WoW finds when reading from the top down, blocks all other GCD abilities afterwards even if that is on cool-down or you don’t have mana or etc.

Assume you have an action that compiles into the following and a, b and c are all on the GCD c will never be cast as it’s always blocked by b. a will cast with the shift mod as it’s evaluated before the b cast but if shift is down a will block b and c.

/cast [mod:shift] a
/cast b
/cast c

This isn’t new. It’s the way it’s always been. Variables only matter in relation to where they are put in the action and the name has a total of 0 meaning.

To see what your action looks like when the variables are added in see the “Compiled Template” button. This thing on the side is actually the macro that GSE sends to WoW. Your KeyRelease variable doesn’t work because you have a GIGO error - Garbage in, Garbage out.

1 Like

I don’t know what happened, but I logged in today and tried a couple new macros to download and they’re working lol. Thanks for all the info!