GSE2.0 How To

I felt very comfortable with everything I had set up with GS:E using the MyMacro folder. Now with all the changes, I feel very much like a deer in headlights. Is there someone who could explain the best way to copy a macro that I was using previously into the new GSE2.0 that came out today? I appreciate the help very much!

Personally, read this post
https://wowlazymacros.com/forums/topic/gse2-and-7-1-5/
It has maked all clear to me, and, when something is kind of confuse, all u need to do is ask, and Timothy will surelly answer.

In game:

  • /gs
  • Import
  • Paste
  • If its an old GSE1 Macro - change the radio button at the top to Legacy
  • Check it has a valid specID - This should be a number.
  • Import
  • Close the Import window
  • If it isnt in the immediate list (The refresh is slow for the fist few hours while its doing a lot of background processing) - close and reopen the /gs window.

If it still doesn’t appear then you may have to go to options and turn on Show All Macros. From here close and reopen /gs find your macro and edit it and Change the Specialisation to match the macro. – this should only happen if you dont have a specID or the specID is a string like “Hunter”

This is the anti Deer video
https://www.youtube.com/watch?v=ox9d0vjdACE

Ok i thought i had it working and it seems i didnt. After importing i hit “create icon” pulled the macros to my action bar. I logged out and back in… no macros on action bar.

There is a step I’m missing somewhere I guess. Unfortunately I tried deleting everything, including WTF folder, so I don’t have anything to import from legacy. So, now that MyMacros is obsolete, how do I use any of the macros on this site in GSE2? I read the posts till my eyes bled, but theres a leap that I am not following. can someone dumb it down for me please?

Hello,

i have a short question too. I can´t find the answer in your tutorial.

In which folder are the new macros saved or how can i copy a macro in GSE2.0?
I don´t ask about old macros to import. I mean the new macros that are written for 2.0. I don´t find a macro folder which all classes are saved.

Could you please help me?

This is the macro I try to import. It shows: Macro Import Successful, but nothing shows up in list.

Sequences[‘GweenBeast’] = {
author=“Gweenn@Bleeding Hollow”,
specID=253,
version=20,
source = “Local”,
helpTxt = “Talents: 3112112”,
StepFunction = GSStaticPriority,
icon=‘INV_MISC_QUESTIONMARK’,
lang=“enUS”,
PreMacro=[[
/targetenemy [noharm][dead]
/cast [target=focus, exists, nodead],[target=pet, exists, nodead] Misdirection
/cast Exhilaration
/cast [combat] Bestial Wrath
/cast [combat] Blood Fury
/cast [combat] Trueshot
/cast [combat] Aspect of the Wild
/cast [combat] Titan’s Thunder
/cast [nopet,nodead] Call Pet 1; [@pet,dead] Heart of the Phoenix
/cast [combat,pet:Spirit Beast,@player] Spirit Mend
/cast [combat,pet,@player] Roar of Sacrifice
/cast [mod] Multi-Shot
]],
“/cast Dire Beast”,
“/cast Kill Command”,
“/cast [talent:6/1] A Murder of Crows; [talent:6/2] Barrage”,
“/cast Mend Pet”,
PostMacro=[[
]],
}

Doesn’t work nothing fires…

any guide on what to install and how to drag your macro what ever you are showing doesn’t work…

Example, i see SAM Assassination. there is a blue book but i can’t drag him on my bar?>?

Very frustrating.

i have problem getting the option button to work.am i doing something wrong or need to do something else? i like GS alot and would like it to work right for me.

So is gs2 fixed yet or still buggy