GSE2 Howto: Fix Unable to import macros.

If you import a macro and it says its successful but you cant see it its because you have a corrupt macro in your GSE Macro Library. GSE 2.1.01 and on have a function that will report these macros when you log in but its not always obvious to th emod which one is at fault. You will have to do some research and look into the problem. The most likely cause of this is trying to import an old GS macro or one that has not been well formed. Its good enough to pass the initial checks and balances but beyond that it is broken.

In GSE2 each macro is stored in a class bucket so that a corruption will not wipe out every character you play. The file that saves your macros is located at c:\path\to\World of Warcraft\WTF\AccountName\YOUR ACCOUNTNAMEHERE\SavedVariables\GSE.lua Deleting the addons GSE folders and redownloading without addressing this file will not achieve anything as no macros are stored in the addon folder.

This file has two sections
Section 1) Mod variables for options
Section 2) GSELibrary
This is structured as:
GSELibrary = {
[0] = {
… Sequences here for Global
},
[1] = {
… Sequences here for Warrior
},
[2] = {
… Sequences here for Paladin
},
etc

Here is an examplke of what you are looking for: Note the amcro names here 911ST is an EXAMPLE, You will need to find your own macro:

    GSELibrary[0]["911ST"] = {
      ["Talents"] = "?,?,?,?,?,?,?",
      ["Default"] = 1,
      ["Author"] = "Unknown Author",
      ["MacroVersions"] = {
        {
          {
            "/cast [@mouseover,help,nodead] Ironbark", -- [1]
            "/cast [@mouseover,help,nodead] Swiftmend", -- [2]
            "/cast [@mouseover,help,nodead] Rejuvenation", -- [3]
            "/cast [@mouseover,help,nodead] Regrowth", -- [4]
            "/cast [@mouseover,dead] Rebirth", -- [5]
            ["source"] = "Local",
            ["author"] = "XXXXXX",
            ["PostMacro"] = "/cast [@mouseover] Rejuvenation\n/cast [@player,combat] Barkskin\n",
            ["version"] = 3,
            ["lang"] = "enUS",
            ["helpTxt"] = "Talents: 1321233",
            ["specID"] = 105,
            ["PreMacro"] = "",
            ["icon"] = "INV_MISC_QUESTIONMARK",
          }, -- [1]
          ["StepFunction"] = "Sequential",
        }, -- [1]
      },
      ["SpecID"] = 0,
    }

This is broken as its a mix of GS and GSE2 format.

The easy way to reset a class is to /run GSELibrary[ClassID] = {} This will wipe all macros for a class. Don’t do this unless you have backed up the GSE.lua file in case you need to get a macro back.

Before doing that though when you login you may receive messages about a macro not loading correctly. I would start with a /run GSELibrary[ClassID]['MacroName'] = {} first before removing all macros for that class.

ClassID’s are:
1 Warrior WARRIOR
2 Paladin PALADIN
3 Hunter HUNTER
4 Rogue ROGUE
5 Priest PRIEST
6 Death Knight DEATHKNIGHT
7 Shaman SHAMAN
8 Mage MAGE
9 Warlock WARLOCK
10 Monk MONK
11 Druid DRUID
12 Demon Hunter DEMONHUNTER

Did Anyone ever figure out how to transfer macros using the send macro to another player button? the couple of times I have tried it never worked… it would definitely make life easier between me testing a fellow macro writers macro and sending it to the wifes computer without me having to jump over a chair to her desk and back again… also when I send a copy of my macros to a buddys …many thanks for info…

@Enmity I never looked at it until recently as no one raised anything about it on Git. The 2.1.03 build has this fixed.

A matter I realized with recent problems are options within GSE itself.

If the imported script doesn’t set a specID and “Show all macros” is not checked, then the macro will not appear in the list. The possibility had never occurred to me as GSE was not fully understood. After learning more about the bells and whistles, I had a true “DOH” moment.

Like great i am a noob where do i run it dos window in wow ?

You completely exit WOW and use Explorer + Notepad on Windows or Finder + Text Edit on a Mac.

@TimothyLuke There is a second option which is getting overlooked…
Its also my preferred method as it is the most efficient.
pcpt

1 Like