GSE2: Where imported macros go when successful and I cant see them

GSE2 has a completly rewritten storage component designed for performance. It only loads the macros designated as being for the class you are playing.

What you can do - Ingame
With GSE 2.0.2 or higher you get these options.

The preferred solution is to press the Red option and then close and reopen /gs Your missing macros should appear at the top. Edit them, change the specialisation to match the spec for the macro and save and you are away.

Alternatively you can turn on the Yellow option but this comes with a performance impact in that it will try to manage every macro in this set even for ones that are not from your class.

You can edit the GSE.lua file in WTF (if you dont know what I am talking about here or how to find this file, this is not the option for you)

In that File is a table called GSELibrary. Within that table there will be an entry that equates to GSELibrary[0] and within that are the missing macros. You need to move the macro from there to GSELibrary[{{Classid}}]. eg for Paladins GSELibrary[2] /gs showspec will tell you your classid. Setting the specid here out of game will not be enough. The macro has to be moved. How do you know when you are in the right part - you need to look at the {} pairs and not muck it up. This is RAW WOW Storage. You can only edit the file with WOW completely shutdown. Backup the file before you start and seriously good luck. I am scared to touch this file.

I follow the steps above with no success.
I can’t create new macros nor import others with my Shaman especifically.
I have tried everything and I don’t know what to do!

i keep getting this error msg when i log in
Date: 2017-01-13 11:45:48
ID: 1
Error occured in: Global
Count: 32
Message: …\AddOns\GSE\API\Storage.lua line 217:
bad argument #1 to ‘pairs’ (table expected, got nil)
[C]: pairs()
GSE\API\Storage.lua:217: ReloadSequences()
GSE\API\Events.lua:98: ?()
[string “safecall Dispatcher[2]”]:4:
[string “safecall Dispatcher[2]”]:4
[C]: ?
[string “safecall Dispatcher[2]”]:13: ?()
…chy\Libs\CallbackHandler-1.0\CallbackHandler-1.0.lua:91: Fire()
Swatter, v7.0.4 (<%codename%>)
Archy, v7.1.0.8
Atlas, v1.36.02
Auctionator, v4.0.16
AuctionatorMiniFeatures, v6.2v1-release
Babylonian, v5.1.DEV.332(/embedded)
BagBrother, v
Bagnon, v7.1.1
Configator, v5.1.DEV.406(/embedded)
DBMCore, v7.1.7
DBMDefaultSkin, v
DBMSpellTimers, v
DBMStatusBarTimers, v
Gatherer, v7.0.4
GSCore, v200
GSE, v204
SlideBar, v7.0.4 (<%codename%>)
BlizRuntimeLib_enUS v7.1.5.70100 <none>

Cannot find any macros for my destro warlock anymore!

getting the same error has chad
also can no longer import or select options but all macros previously imported still work

can no longer import or select options but all macros previously imported still work. Me to-