Gurus! Please Help

Hey there - I use these macros on all of my characters, and use modifiers on each.

But there is one character - a warlock - that the mod:alt one isn’t working on.

As luck would have it I have two locks, and when I switch to the other lock and use the same macro it all works. But for some reason it won’t on the first lock.

I’ve tried switching the alt and ctrl mods around, but whatever is attached to the alt one won’t fire. I’ve tried putting the macro on buttons 2 and 3, still won’t fire. I’ve copied the Elvui settings from the lock that worked, still no luck. And I can’t find any keybindings that use alt+1, alt+2 etc. I’ve even taken the ‘self-cast’ alt setting and changed it to none.

Just to be clear - my mod:alt calls work on every other character I have, and the same macro works 100% fine on my other lock. It is something unique to this character.

If any gurus out there can offer a suggestion it would be much appreciated!


are the keybindings the same across all characters? there could be a difference

Also check if a mod is enabled for one lock and not the other.

Yeah checked all the character specific and non-character specific keybindings, even took screenshots to compare. No difference.

I did get a fix however - hopefully it helps someone else who may be stuck…I bound alt+1 and alt+2 to random empty slots then removed each one. All works now.

Thanks for the help anyways!