Having a strange issue

@TimothyLuke I am currently working on a new demonology macro. I am having an issue where the first command I am putting in my variable KeyPress will go into says after it cycles the macro once.

I have never seen this issue, and thought maybe I input a bad command, so I switched to a different command and has same issue.

the original command I had was /targetenemy [noharm][dead] . Like I said worked then after it cycled started putting that into says. So I deleted it and rewrote it same issue. So I decided I would change the placement of the command after /petattack. So keypress look like this
/targetenemy [noharm][dead]
ran the macro and it worked and after it cycled it started putting /petattack in says.
Hoping you have an idea on how I can fix this issue I am having, because I am stumped.



I have some of similar issues like you mentioned above…

hard to test a macro, I don’t want to keep flooding chat with a command. I have even copied it to a different macro. That did not help, like I said I am stumped.

I have even copying my KeyPress from different macros, tried putting spell cast there, still throwing text into says. I am just going to shutdown the writing of macros for a little bit. And try a different toon using the macro, and other macros to see if it is something that has changed. shrug

Like I said. It is seems like the Old platform of GSE Macro from Shadowland still work accordance. Like the issue with /targetenemy.

not sure, first time I ran into this issue, I always use /targetenemy [noharm][dead] in my macros.
But it will send commands to says even if it is a /cast command. I moved /cast [nomod,combat,nopet,exists] Fel Domination, to the first line and it will send that to says after it cycles once.

I guess I can try and recreate the macro, only took me about 2-3 hours to write. Might just move key pieces of the macro to an old macro and see if I can cheat my way around it. But I still want to learn how to fix this issue. I have been combing over it now for awhile since I posted the issue, and I combed through it for a long time before I asked for help. I hate bothering @TimothyLuke for an issue if it is something stupid I did myself. More so on a Holiday when he should be getting fat on turkey and all the fixings.

I totally understand… same here my friend

It’s not a holiday for me - I’m in Australia.

Most likely you have an erroneous space in front of the variable.

yeah what I thought and deleted it, happened all the versions, I just used an old macro and worked around it. I never could find the cause. TY for the reply.
I never did find the root cause. Just fixed it differently. could not find a space or anything that was out of the ordinary.