How to cancel / reset macro in Classic WoW?

Good morning / evening,

I’ve tried changing the options in GSE, using various options such as mouse right-click, mouse button 5, any alt / ctrl / shift, but nothing seems to cancel my macro sequence.

In short, I’ve created a sequence for DoTs, but I want the entire macro to reset if I change target, which is only possible through /castsequence.

I noticed the UI mentioned updating the Macro Stub, but the description isn’t very clear, at least for my uneducated mind.

I’ve tried deleting the macro icon, recreating it, changing the macro icon and name in /macro, all before and after updating the macro stub with this reset key.

I’m not sure if this is relevant, but I noticed when GSE creates the macro in /macro, there’s a lot of references to button this and button that. I’m not clear what that means or if it’s related.

I’ve also tried deleting the entire macro and recreating it. Is this a bug that I need to submit on GitHub, or am I just ignorant about how this is supposed to be configured and used?

GSE has the option that you can set a key combination to manually reset any macro to its line 1 first run state. In GSE’s options you can configure a combination like Right shift + macro to reset. That’s what all those button things are about.

If you had old macro’s, the Update Macro Stubs button would convert /click macroname to the extended format.

Good morning Timothy,

I’ve tried various combinations here, but nothing seems to reset the macro execution. Here’s what I’m expecting to happen.

Macro Sequence (example only):
/cast Curse of Agony
/cast Corruption
/cast Siphon Life
/cast Immolate

If I finish at Corruption in the macro sequence, and switch targets, it picks up at Siphon Life. But you know this, and this is working by design for GSE.

I could use /castsequence reset=target, but then that would limit me using other /cast commands with conditionals, with how you’ve outlined /castsequence steps through a macro sequence.

I want to be able to be able to cast an arbritary number of DoTs, switch target and press Mouse Button 5 to reset the sequence, and start over with the DoT rotation.

Since I don’t exit combat, GSE doesn’t reset the macro sequence, and Mouse Button 5 isn’t resetting it either. Thus my question: is this a bug, or am I expecting this to function different than it’s designed?

A couple of things - You need to ensure that Mouse Button 5 is being recognised by WoW. The next question is is it getting to GSE.

The way to check this is to create a macro in /macro

/run print("Mouse Button Clicked: " .. GetMouseButtonClicked())

If this prints out Button 5, then it is getting to WoW.

In GSE’s options, the next step is to go to Options, turn on debugging and on the debug tab turn on the ability to see “Print KeyPress Modifiers on Click” <— warning this will generate a ton of crap in your chat window.

If that is the case then go to a target dummy and turn off AHK or similar. run /gs debug This is different from the other debug and will let you walk through your macro line by line. run a few lines and then reset it via your button and check that it goes back to the beginning of your macro.