How to get old WW Macro to work?

Hey monks out there,
since the new addon alot has changed. Also the macros we were able to use last expansion.

THIS macro is one of them that doesn’t work since WoD

/targetenemy [noharm][dead]
/castsequence reset=15/combat/target Disable,null
/castsequence [nochanneling]reset=0.3 0,0,0,0,expel harm
/castsequence [nochanneling]reset=0.3 0,0,0,Chi Wave
/castsequence [nochanneling]reset=0.3 0,0,Blackout Kick
/castsequence [nochanneling]reset=0.3 0,Jab,jab
/castsequence [nochanneling]reset=combat !Rising Sun Kick,Tiger Palm,Blackout Kick,!Rising Sun Kick,Tiger Palm,Blackout Kick,disable
/cast touch of death
/use [combat]Energizing Brew
/use [combat]chi brew

But it was one of the best macro I had. Does anyone of you maybe know how get that macro back to work with gnomesequencer or macro tool kit?

Please help!

Hey man! I Will try to get an solution for this but im sure this macro is dead.

Ill re-tweak this and come with a response.


Hey Mate. I’m Back with an macro that does not lock up for me and that is doing over 200k with my level 92 monk at orgrimmar dummy. This’ll probably work very well for your level 100, just add the last talent spell in the end of the both lines and it’ll work good in my thoughts.

Remember that to use your own Tigereye Brew because I did not get it to work in the macro that well, but here it is and I hope you enjoy it.

/castsequence [nochanneling] reset=target Jab,Tiger Palm,Jab,Rising Sun Kick,Jab,Blackout Kick
/castsequence [nochanneling] reset=target Jab,Tiger Palm, Jab,Rising Sun Kick, Jab, Blackout Kick
/castsequence [nochanneling] reset=target Jab,Jab,Blackout Kick, Rising Sun Kick
/cast [nochanneling] !Invoke Xuen, the White Tiger
/cast [nochanneling] !Energizing Brew
/cast [nochanneling] !Chi Wave
/use 13
/use 14
/startattack [noharm,combat]

This is for MACRO_TOOLKIT usage, so do not have any other installed, e.g gnome, superduper, or else this might fall into a failure issue.


Oh damn…why in hell does that macro not wanna work anymore.
But, well, I’ve tried your macro. Changed the 90’s Talent to RJW.

I’ m lvl 100 with little bit about 630 gear.
The first try I did like 14k on the 102 dummy in my garnison. Then i tried of course again and it started to lock up after a few seconds :\ Can’t really tell why it’S doing that -.-

BUT I’m very thankfull for your help. I guess that’s the start to get the old macro back :smiley: Eventually other gamers are trying your macro and will give us feedback.


This isn’t possible anymore. It’s blizzard and interface related. They changed it to prevent all-in-one macros like that. The closest thing you’ll see is using gnomesequencer and working on the spell priorities with it. I’m not going to work on this right now since I’m not planning playing with my monk for the next 2 months, maybe. But you can try messing with gnomesequencer.

Tip: when changing gnomosequencer macros file, you can change the macros and then coming back to game and do a /reloadui to immediately reflect the changes.