Is anyone else having issues with GSE 3 and version 9.2

Anyone else having issues with GSE 3 and version 9.2.0? Not operating like previous GSE versions.
if so are there any fixes? Possibly a GSE 3 and wow v9.2.0?

i havnt had a issue yet with GSE in this patch. you might need to elaborate more on what the issue is please. this way we can help.

There is a GSE3 for WoW 9.2 it’s v3.0.61 and is available on Curseforge. That is the first thing to check. Beyond that you would actually need to provide some information that is useful beyond “I think there might be a problem, could you please tell me what my problem is and how to fix it.”

1 Like

I had not played in the last 3 month. I updated everything before playing. I have 3.0.61, the latest wow patch. The macros I was using have suddenly stopped performing well. I thought it was my toon, I was leveling my Horde MM L57 now. I also tried them on my Alligence MM L 60 wirh the same outcome. I am running my Logitech M502 mouse. I have duplicated this on both my laptop Win 11, and desktop Win 10, yes I have 2 of the same mouse, set at 250ms.
I did a fresh install of GSE on my desktop, tried writing a new macro all day yesterday. I just cant seem to figure out why I cant get above 2.3 dps and thats burst. I will get figured out.

what other info would be helpful? I mainly do PVE and like these talents 1122232. I wish I would have kept all my AHK macros.
I sim’d Bownhan@Stormrage this morning and I should be pulling way more than I am.

what iLvl are you trying these out on? what macros are you using?

1 Like

My problem is a memory issue I think. only 8GB running at 53% on my laptop. I believe I have the same issue with my desktop. I will check that tomorrow.

Thanks for your input, It jogged my brain in the correct direction. Darn TBI, That is why I use GSE.

1 Like

If your running low on RAM, look for any macros you are not using and delete the Icon for them - this will return more system Resources to your computer

1 Like

Well I guess 8Gb of ram is no longer good enough. Thank you for your replies, I still feel like a dumb butt.


i use 8gb of ram on my computer and play very well for me.

Might want to check your Virtual Memory settings too. I have 24G of ram and was running like dog poop (I have a slightly older cpu too tho) until I bumped up my setting to the windows recommended 1.5x my ram size. Figure any little tip might help in the end.

1 Like

I’ve been getting an error when joining pvp matches. I haven’t really payed attention, Just notice it shows and error window and says something about gse. I’ll screenshot it next time it happens today. Thats the only time i’ve ever had issues with GSE.

Thanks for the post. My issue turned out to be PC memory, I upgraded it and it was good,

My Issue turned out to be RAM. My PC wanted more than 8GB. I upgraded and all is good. thank you for the post.


I forgot to get a screen of some of the random issues during PVP but I did catch this one.

For something like this, I would recommend going into /GSE and removing the Icon from any macros you are not using right now. From what I understand this will allow the addon to ignore them during runtime.