Issue with action bar set as shift

Ive been running gaupandas BM and MM macros using

/click [mod:shift] GAUPANDA_MM_MT
/click [nomod:shift] GAUPANDA_MM_ST

/click [mod:shift] GAUPANDA_MT
/click [nomod:shift] GAUPANDA_BM_ST

up until today these were working perfectly, after updating elvui to the current version i now have the issue thats causing the shift mod to no longer function. if i set it to “none” the mod works but if you log out and come back it reverts to shift and the problems back. i know this is not a gse problem exactly but i would like to know if this a known current issue

i have checked literally everything else that i should have and this actionbar thing seems to be the only thing affecting it

is set as this as it has been for years

change it to this and macro will fire and shift mod works

Any form o log out or reload and it reverts and the previously mentioned problem returns

1 Like

Yep need to clear the keybind except Elv keeps putting it back. Unfortunately the simplest solution to these problems that keep occurring is to not use ElvUI until they sort their stuff out.

Why is this an issue now when it hasn’t been before? Because Blizzard completely overhauled the UI and not just cosmetically. There is a complete new rule book for mods and mod authors are finding out the hard way that a lot of what used to work particular ways now doesn’t. It either doesn’t work at all or activating it breaks something else.

Yup, same thing happened to me. Decided to remove Elvui and make default work with a few addons, spent the whole day tweaking ui. It’s a mission and still not comfortable with everything but nearly there.

Elvui just had to many things not working since this change like bag disenchant etc. It will continue while Blizz keeps making changes to the default.

i thought this was the case, i thought it was worth a mention in case others were running into the same problem. looks like its back to default for the time being. thanks for taking the time to reply guys

there is also a “duplicate” setting in ElvUIs action bar settings.
ElvUI → Action Bars → General
There is a setting to lock action bars and when checked you can choose a modifier key.
This overwrites the games setting on reload.
Just faced a similar issue and was able to solve it by setting it in ElvUI.

i have no issue with Evlui (have the newest release) and shift mods in macros. guess i’m just lucky. i do use Guapanda’s MM and BM also.

Same as @Siodar. I haven’t encountered anything on my end either.

I do have the exact same issue as of a few days ago, worked fine before. must have been smth in the latest elvui updates.

Fixed it with disabling the Lock Actionbars option.

1 Like

Unbind the shift key and or remove ElvUI and problem solved. Like the post directly above yours has the solution.

Esc ==> Options ==> Action Bars then set the ‘Lock Action Bars’ button to 'None"

Unfortunately it looks like you will need to do this every time you log on until Elvui fixes it.