Anyone else notice stuttering lag when using GS? I use my Razor to spam the button while held, but not since prepatch the game has this weird lag issue.

I’m using the old GS not GS-E. Has anything changed performance wise between the two? I would figure the guts of the addon worked the same.

I cant answer that directly as I no longer use GS. To do an apples to apples test, I would just install GS-Core from GS-E and drop in your sequences file as if it was GS. There are a lot of differences in the GS-Core code now to what was in GS but it follows the same ideas and has backwards compatability.

The other thing to try is set up a simple /castsequence macro independant of GS and GS-E and see how you go spamming that and do you still get the same lag as the problem may be down underneath what GS and GS-E do.

it has something to do with the speed of the clicks and the cast time / animation time for some classes.
as well as another factor i cant put my finger on but seems to be PC related.

I usually run mine on a mouse button set at 4 milliseconds, and all is fine. If i have been on for an extremely long time. on fights where there is a lot of effects going off at ones it will lag in framerate while i hold the button down but smooth as silk when doing nothing. which i resort to manually tapping the key and all is well.

The other effect which happens to mainly my Huner and Warlock macros is if I hold the macro running at that speed for more than 30 seconds it will disconnect me from the game. this seems to be an ability or spell that causes this when spammed so fast.

slowing my speed down does remove these issues. which is why i believe its the speed the macro is fired off at.

I think WoW was lagging earlier today, I noticed it earlier and gave up playing for awhile around the time you posted this… The lag wasn’t only when running my macro but when I pressed other abilities manually.

Mine isn’t lagging … I switched post patch to GS-E … its muuuchh nicer. I’m running on a Mac though so your milage may vary. Who is your network provider and what kind of lag are you getting?

It’s not the gnomesequencer it’s wow that is making you lagg sometimes